summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-08-29 20:57:19 +0100
committerJames Le Cuirot <chewi@gentoo.org>2020-08-29 20:57:19 +0100
commit20bde3f8905f18eb620d2bc4c98d63f64b49549a (patch)
tree04ec1632fbc1c50f7e2a71bea4f4227c8af0dcbd /dev-util/patchelf
parentsys-apps/portage: Stabilize 3.0.4-r1 sparc, #739446 (diff)
downloadgentoo-20bde3f8905f18eb620d2bc4c98d63f64b49549a.tar.gz
gentoo-20bde3f8905f18eb620d2bc4c98d63f64b49549a.tar.bz2
gentoo-20bde3f8905f18eb620d2bc4c98d63f64b49549a.zip
dev-util/patchelf: Version bump to 0.12
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/patchelf-0.12.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
index 4ac2f5003ee5..f9192d349b50 100644
--- a/dev-util/patchelf/Manifest
+++ b/dev-util/patchelf/Manifest
@@ -1,2 +1,3 @@
DIST patchelf-0.10.tar.bz2 158604 BLAKE2B 6aed9c2e7f37ff0330ca517a9491c46a93212140367b720bf94da4e4ec29a4978c920b53ce306ec333b3f7ac0216ff59637048c6997cfea4a34a87f2a0448796 SHA512 647ad13b7d45b3c5d20683ef8fe9760cb7f213e879231b6c5780bf32771adfbf7c5e5ce694c08e5681dceda63857d7d8a2d53efb60f799d3e7290cebc02ab501
DIST patchelf-0.11.tar.bz2 159046 BLAKE2B 48d8dd986c681facd8d925d8f471ed6b4cae6a06472d66c1c22a32ded796f50be8d30cefc2847890558c2799707c33beb64ffc5d09f6d142120363bea5e40456 SHA512 ad3a99db6952412a2dac27256640cb9152b8bf5d189f1685b7478b9773bb612e06621511fc7338b2defc435bcdc26f67f79c2d830570a6da70f9d280b123d977
+DIST patchelf-0.12.tar.gz 103075 BLAKE2B 8ea71eb75bcc40e18a168c1e65856809fcceb8f68a9939e5248464d8c2e5d14d4eb1278965727417a26e70734712121d057c3da689be397f93bdb5234a11d5ba SHA512 2563a5b22b90392d5755d9a08022daf8570fa1b741becbbca92548d0a2f82f7ee21175a2c34816a4653c89c2219bf59b1440304b0fa2d49842e398ab18b9923c
diff --git a/dev-util/patchelf/patchelf-0.12.ebuild b/dev-util/patchelf/patchelf-0.12.ebuild
new file mode 100644
index 000000000000..b3d5fb270ec6
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://nixos.org/patchelf.html"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_test() {
+ emake check \
+ CFLAGS+=" -no-pie" \
+ CXXFLAGS+=" -no-pie"
+}