summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-06-13 18:49:32 -0400
committerMike Pagano <mpagano@gentoo.org>2024-06-13 18:49:32 -0400
commitbb788d4ba77748d5d6817385ac011651ac92ffc7 (patch)
tree1177258fc56bc2a3bb08c07b8f048209fab910c8 /dev-util/idea-community
parentdev-python/fonttools: Keyword 4.53.0 for ~m68k (diff)
downloadgentoo-bb788d4ba77748d5d6817385ac011651ac92ffc7.tar.gz
gentoo-bb788d4ba77748d5d6817385ac011651ac92ffc7.tar.bz2
gentoo-bb788d4ba77748d5d6817385ac011651ac92ffc7.zip
dev-util/idea-community: add 2024.1.3
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'dev-util/idea-community')
-rw-r--r--dev-util/idea-community/Manifest2
-rw-r--r--dev-util/idea-community/idea-community-2024.1.3.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/dev-util/idea-community/Manifest b/dev-util/idea-community/Manifest
index f041caffffd2..b2f2596a5a0e 100644
--- a/dev-util/idea-community/Manifest
+++ b/dev-util/idea-community/Manifest
@@ -1,2 +1,4 @@
DIST idea-community-2024.1.2-aarch64.tar.gz 818853263 BLAKE2B f163233e351a35d4cb9863553462050a3d85d77566b7e7837f3f67648e8071ad1a2d8cc3ef4406210624c91cd016da434ef1a2c11d671c97e89f487347f57919 SHA512 4f45e2dac8917120ca1d3b4c1349d5dc2380de890e5b5f3e0f330a2863110ac71b33218b853fd56b3a9e3a304cb8ac96c95ff5798beeb97af9081e56e9e8a115
DIST idea-community-2024.1.2-amd64.tar.gz 819182024 BLAKE2B 1483b55f3977f9e7727a5b9b156b66c53b3f20c61b7cb71107384ebb820b71118027e9eb9395f39abd24536157dd1dfd0350ead9a99214d87ee483e50cd4f199 SHA512 881f18dc080d0cd13515dcf2deee57e5b9c46b4fe2580bd5f5f353bba9cf6458477ae9284b8f003b44d8527e5530335d894671777cd3c5d7ee822fdb79d46ad9
+DIST idea-community-2024.1.3-aarch64.tar.gz 818953364 BLAKE2B 12eaf0880eee7c8236d9a12c17ce4a3faca285f96b863623c8ff4a55ef12cb392cf5f741aa4b194caf11ea413318e2a7222366dacc1572d8b5b273e7a80c4a83 SHA512 2ff73e52c2c62e8040b028a240d512c4eec60ec6522a922686760727cf0169283be707d3c2874017c33e176410994e9fd6cc1c62eb625fd9926ad4aa36e6bd11
+DIST idea-community-2024.1.3-amd64.tar.gz 819289015 BLAKE2B 872d15e22da0de9b21fd6ef0f7790e98becf6d8ba25c403ef109bdb1c98313e7f97728b5ed4221cba74451b37b93542355435df6356d9a0d0e0788dca0f2e7ea SHA512 36ae924c9b7be00c03b01642b9d88ff1fd4703cff760548782557f40075a10317db6184ab4eb7dc05ebc3d3cb41e20ef0f9dcc850640ef8ea15edccac4221e04
diff --git a/dev-util/idea-community/idea-community-2024.1.3.ebuild b/dev-util/idea-community/idea-community-2024.1.3.ebuild
new file mode 100644
index 000000000000..ca53839b9825
--- /dev/null
+++ b/dev-util/idea-community/idea-community-2024.1.3.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop wrapper
+
+MY_PV=$(ver_cut 1-3)
+
+DESCRIPTION="A complete toolset for web, mobile and enterprise development"
+HOMEPAGE="https://www.jetbrains.com/idea"
+
+SRC_URI="
+ amd64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm64? ( https://download.jetbrains.com/idea/ideaIC-${MY_PV}-aarch64.tar.gz -> ${P}-aarch64.tar.gz )
+ "
+
+S="${WORKDIR}/idea-IC-${PV}"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 CC-BY-2.5 CDDL-1.1
+ codehaus-classworlds CPL-1.0 EPL-1.0 EPL-2.0
+ GPL-2 GPL-2-with-classpath-exception ISC
+ JDOM LGPL-2.1 LGPL-2.1+ LGPL-3-with-linking-exception MIT
+ MPL-1.0 MPL-1.1 OFL-1.1 ZLIB"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+DEPEND="
+ || (
+ >=dev-java/openjdk-17.0.8.1_p1:17
+ >=dev-java/openjdk-bin-17.0.8.1_p1:17
+ )"
+
+RDEPEND="${DEPEND}
+ sys-libs/glibc
+ media-libs/harfbuzz
+ dev-java/jansi-native
+ dev-libs/libdbusmenu"
+
+BDEPEND="dev-util/patchelf"
+RESTRICT="splitdebug"
+
+QA_PREBUILT="opt/${PN}/*"
+
+src_unpack() {
+
+ default_src_unpack
+ if [ ! -d "$S" ]; then
+ einfo "Renaming source directory to predictable name..."
+ mv $(ls "${WORKDIR}") "idea-IC-${PV}" || die
+ fi
+}
+
+src_prepare() {
+
+ default_src_prepare
+
+ if use amd64; then
+ JRE_DIR=jre64
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-aarch64/libquiche.so
+ else
+ JRE_DIR=jre
+ rm -vf "${S}"/plugins/cwm-plugin/quiche-native/linux-x86-64/libquiche.so
+ fi
+
+ PLUGIN_DIR="${S}/${JRE_DIR}/lib/"
+
+ # rm LLDBFrontEnd after licensing questions with Gentoo License Team
+ rm -vf "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend
+ rm -vf ${PLUGIN_DIR}/libavplugin*
+ rm -vf "${S}"/plugins/maven/lib/maven3/lib/jansi-native/*/libjansi*
+ rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le
+ rm -vf "${S}"/bin/libdbm64*
+ rm -vf "${S}"/lib/pty4j-native/linux/mips64el/libpty.so
+
+ if [[ -d "${S}"/"${JRE_DIR}" ]]; then
+ for file in "${PLUGIN_DIR}"/{libfxplugins.so,libjfxmedia.so}
+ do
+ if [[ -f "$file" ]]; then
+ patchelf --set-rpath '$ORIGIN' $file || die
+ fi
+ done
+ fi
+
+ rm -vf "${S}"/lib/pty4j-native/linux/x86-64/libpty.so
+
+ sed -i \
+ -e "\$a\\\\" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$a# Disable automatic updates as these are handled through Gentoo's" \
+ -e "\$a# package manager. See bug #704494" \
+ -e "\$a#-----------------------------------------------------------------------" \
+ -e "\$aide.no.platform.update=Gentoo" bin/idea.properties
+
+ eapply_user
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ local dst="${D}${dir}"
+
+ insinto "${dir}"
+ doins -r *
+ fperms 755 "${dir}"/bin/{format.sh,idea.sh,inspect.sh,restarter,fsnotifier}
+ if use amd64; then
+ JRE_DIR=jre64
+ else
+ JRE_DIR=jre
+ fi
+
+ JRE_BINARIES="jaotc java javapackager jjs jrunscript keytool pack200 rmid rmiregistry unpack200"
+ if [[ -d ${JRE_DIR} ]]; then
+ for jrebin in $JRE_BINARIES; do
+ fperms 755 "${dir}"/"${JRE_DIR}"/bin/"${jrebin}"
+ done
+ fi
+
+ # bundled script is always lowercase, and doesn't have -ultimate, -professional suffix.
+ local bundled_script_name="${PN%-*}.sh"
+ make_wrapper "${PN}" "${dir}/bin/$bundled_script_name" || die
+
+ local pngfile="$(find ${dst}/bin -maxdepth 1 -iname '*.png')"
+ newicon $pngfile "${PN}.png" || die "we died"
+
+ make_desktop_entry "${PN}" "IntelliJ Idea Community Edition" "${PN}" "Development;IDE;"
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
+
+ # remove bundled harfbuzz
+ rm -f "${D}"/lib/libharfbuzz.so || die "Unable to remove bundled harfbuzz"
+
+ # remove bundled java
+ rm -r ${dst}/jbr || die "Unable to remove bundled java"
+
+}