summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-08 12:22:31 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-08 12:22:31 -0400
commit71a912fd930cd2b97699fa37aea74a3b7499efa2 (patch)
tree7164068a8abf53ccbd50f1bb192d5659dcc89b59 /dev-util/directx-headers
parentsys-apps/acl: Fix build with musl 1.2.4 (diff)
downloadgentoo-71a912fd930cd2b97699fa37aea74a3b7499efa2.tar.gz
gentoo-71a912fd930cd2b97699fa37aea74a3b7499efa2.tar.bz2
gentoo-71a912fd930cd2b97699fa37aea74a3b7499efa2.zip
dev-util/directx-headers: Version bump to 1.610.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/directx-headers')
-rw-r--r--dev-util/directx-headers/Manifest1
-rw-r--r--dev-util/directx-headers/directx-headers-1.610.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/directx-headers/Manifest b/dev-util/directx-headers/Manifest
index 31330413718e..c10c2a6326ae 100644
--- a/dev-util/directx-headers/Manifest
+++ b/dev-util/directx-headers/Manifest
@@ -1 +1,2 @@
DIST directx-headers-1.608.2b.tar.gz 395823 BLAKE2B 72bb71b75895afb0407af674d9877b680f77eb3133d2b23b833dff4b43230960f88fdc083d714fb09556d9babb530c34642dd3835b3fdc809473abb601ae8aab SHA512 d4e82615751d9ee46c456c676bfd6831c47d159ee58634531fc1acd09927f00c4e8d379cb233a1f89e3489a6a30d8edc0552b76945071badaed6a9c8591cbb0c
+DIST directx-headers-1.610.2.tar.gz 407869 BLAKE2B aacfaf056871f2df1b09dc8ead62af81bbd91071b6de6c2b014fdb54b6eaa39cf8cc7aafda0f2f06282bb1c0f272bd8a59aee662285a2507e9c119928f89cb92 SHA512 37781f20b533c68d2adacda36936e70d43cf83b108ec76b224b0633760f8e993467618e40b21dd4a71ff314f1b35e3812d7ec85663696bab7132222d1fb5b987
diff --git a/dev-util/directx-headers/directx-headers-1.610.2.ebuild b/dev-util/directx-headers/directx-headers-1.610.2.ebuild
new file mode 100644
index 000000000000..ad4198c30d5e
--- /dev/null
+++ b/dev-util/directx-headers/directx-headers-1.610.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=DirectX-Headers
+inherit meson-multilib
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/microsoft/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/microsoft/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}"/${MY_PN}-${PV}
+fi
+
+DESCRIPTION="DirectX header files and WSL stubs"
+HOMEPAGE="https://github.com/microsoft/DirectX-Headers"
+
+LICENSE="MIT"
+SLOT="0"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dbuild-test=false
+ )
+
+ meson_src_configure
+}