summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dejagnu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dejagnu')
-rw-r--r--dev-util/dejagnu/Manifest2
-rw-r--r--dev-util/dejagnu/dejagnu-1.4.4-r3.ebuild38
-rw-r--r--dev-util/dejagnu/dejagnu-1.5.ebuild28
-rw-r--r--dev-util/dejagnu/files/dejagnu-1.4.4-rsh-username.patch45
-rw-r--r--dev-util/dejagnu/files/dejagnu-1.4.4-testglue-protos.patch21
-rw-r--r--dev-util/dejagnu/files/dejagnu-ignore-libwarning.patch23
-rw-r--r--dev-util/dejagnu/metadata.xml5
7 files changed, 162 insertions, 0 deletions
diff --git a/dev-util/dejagnu/Manifest b/dev-util/dejagnu/Manifest
new file mode 100644
index 000000000000..6e9e55a95e0a
--- /dev/null
+++ b/dev-util/dejagnu/Manifest
@@ -0,0 +1,2 @@
+DIST dejagnu-1.4.4.tar.gz 1080346 SHA256 d0fbedef20fb0843318d60551023631176b27ceb1e11de7468a971770d0e048d SHA512 fae08d4801b6a815af8771896e6e5eb12b297b773faa89743eac28d08c7eac6ed7e530921acdba1b9a7903990060c520497d281651d29d98ab0def1dbfab392e WHIRLPOOL beddb08790591bd817b6096c8ee9f02e2b7e921420658eaebaadc2e1b806d5114632d3adea95d5e5814c4dedc542521582360a03d16f1cc5236052ccbbf149a4
+DIST dejagnu-1.5.tar.gz 576269 SHA256 c8b45808357a6f3e32cd56d8b56a4fdf8a1d5f3818818045c2022993e0e8a3db SHA512 a9486e28f7ce25c34b59d00c0e4862bbb4b7a01d8faae0d1f28669b9d3ded9ed233b892aa27c34e1d06911f071d894aba7c1469e2fd0bddaa5611c2383e4974f WHIRLPOOL 3bc4b393f8f6185f8cce4afcb255a18d11342f14d29eed0e0fc2fd4baf106db707c520802c4913d9c2df3c3dba254c79e1da89e565fd9d5b768e7b4a2abe9912
diff --git a/dev-util/dejagnu/dejagnu-1.4.4-r3.ebuild b/dev-util/dejagnu/dejagnu-1.4.4-r3.ebuild
new file mode 100644
index 000000000000..65f1aba8927d
--- /dev/null
+++ b/dev-util/dejagnu/dejagnu-1.4.4-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="framework for testing other programs"
+HOMEPAGE="http://www.gnu.org/software/dejagnu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc"
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/dejagnu-ignore-libwarning.patch
+ epatch "${FILESDIR}"/${P}-rsh-username.patch
+ epatch "${FILESDIR}"/${P}-testglue-protos.patch
+}
+
+src_test() {
+ # if you dont have dejagnu emerged yet, you cant
+ # run the tests ... crazy aint it :)
+ type -p runtest || return 0
+ emake check || die "check failed :("
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ use doc && dohtml -r doc/html/
+}
diff --git a/dev-util/dejagnu/dejagnu-1.5.ebuild b/dev-util/dejagnu/dejagnu-1.5.ebuild
new file mode 100644
index 000000000000..7207e71a01fa
--- /dev/null
+++ b/dev-util/dejagnu/dejagnu-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="framework for testing other programs"
+HOMEPAGE="http://www.gnu.org/software/dejagnu/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="doc"
+
+DEPEND="dev-lang/tcl
+ dev-tcltk/expect"
+
+src_test() {
+ # if you dont have dejagnu emerged yet, you cant
+ # run the tests ... crazy aint it :)
+ type -p runtest || return 0
+ emake check || die "check failed :("
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ use doc && dohtml -r doc/html/
+}
diff --git a/dev-util/dejagnu/files/dejagnu-1.4.4-rsh-username.patch b/dev-util/dejagnu/files/dejagnu-1.4.4-rsh-username.patch
new file mode 100644
index 000000000000..ff4e970a4fd4
--- /dev/null
+++ b/dev-util/dejagnu/files/dejagnu-1.4.4-rsh-username.patch
@@ -0,0 +1,45 @@
+fix from upstream:
+
+2004-03-05 Daniel Jacobowitz <drow@mvista.com>
+
+ * lib/remote.exp (standard_spawn): Fix rsh username support.
+
+diff --git a/lib/remote.exp b/lib/remote.exp
+index b57276e..cdec0d2 100644
+--- a/lib/remote.exp
++++ b/lib/remote.exp
+@@ -860,19 +860,18 @@ proc standard_spawn { dest commandline } {
+ set RSH [board_info $dest rsh_prog]
+ }
+
+- if ![board_info $dest exists username] {
+- set rsh_useropts ""
+- } else {
+- set rsh_useropts "-l $username"
+- }
+-
+ if [board_info $dest exists hostname] {
+ set remote [board_info $dest hostname]
+ } else {
+ set remote $dest
+ }
+
+- spawn $RSH $rsh_useropts $remote $commandline
++ if ![board_info $dest exists username] {
++ spawn $RSH $remote $commandline
++ } else {
++ spawn $RSH -l [board_info $dest username] $remote $commandline
++ }
++
+ set board_info($dest,fileid) $spawn_id
+ return $spawn_id
+ }
+@@ -1257,6 +1256,8 @@ proc remote_expect { board timeout args } {
+ }
+
+ if {$code == 1} {
++ if {[info exists string]} {send_user "ERROR OCCURED: $errorInfo $errorCode $string"}
++
+ if { $error_sect != "" } {
+ set code [catch {uplevel $error_sect} string]
+ } else {
diff --git a/dev-util/dejagnu/files/dejagnu-1.4.4-testglue-protos.patch b/dev-util/dejagnu/files/dejagnu-1.4.4-testglue-protos.patch
new file mode 100644
index 000000000000..4ddaffb1c66d
--- /dev/null
+++ b/dev-util/dejagnu/files/dejagnu-1.4.4-testglue-protos.patch
@@ -0,0 +1,21 @@
+fix from upstream:
+
+2004-08-20 Daniel Jacobowitz <dan@debian.org>
+
+ * testglue.c: Prototype abort(3) and exit(3).
+
+diff --git a/testglue.c b/testglue.c
+index 55a7f92..4ede6eb 100644
+--- a/testglue.c
++++ b/testglue.c
+@@ -40,6 +40,10 @@
+ #define ORIG_ABORT __wrap_abort
+ #define ORIG_MAIN __wrap_main
+ #endif
++
++extern void abort (void);
++extern void exit (int);
++
+ #endif
+
+ #ifdef REAL_MAIN
diff --git a/dev-util/dejagnu/files/dejagnu-ignore-libwarning.patch b/dev-util/dejagnu/files/dejagnu-ignore-libwarning.patch
new file mode 100644
index 000000000000..f4af06e6ff89
--- /dev/null
+++ b/dev-util/dejagnu/files/dejagnu-ignore-libwarning.patch
@@ -0,0 +1,23 @@
+dejagnu/ChangeLog
+ * lib/target.exp (prune_warnings): Correct pic/PIC regexp.
+ Ignore incompatible library warning.
+
+Index: dejagnu/lib/target.exp
+===================================================================
+RCS file: /cvs/src/src/dejagnu/lib/target.exp,v
+retrieving revision 1.12
+diff -u -p -r1.12 target.exp
+--- dejagnu/lib/target.exp 21 Apr 2002 08:47:07 -0000 1.12
++++ dejagnu/lib/target.exp 9 Jun 2003 07:34:06 -0000
+@@ -279,7 +279,10 @@ proc prune_warnings { text } {
+ regsub -all "(^|\n)\[^\n\]*: warning: as it has already been specified\[^\n\]*" $text "" text
+
+ # Cygwin cc1 warns about -fpic and -fPIC
+- regsub -all ".*: warning: -f(pic|PIC) ignored for target .*" $text "" text
++ regsub -all "(^|\n)\[^\n\]*: warning: -f(pic|PIC) ignored for target \[^\n\]*" $text "" text
++
++ # Ignore linker warning when searching 64bit libraries in /lib.
++ regsub -all "(^|\n)\[^\n\]*: skipping incompatible \[^\n\]* when searching for \[^\n\]*" $text "" text
+
+ # It might be tempting to get carried away and delete blank lines, etc.
+ # Just delete *exactly* what we're ask to, and that's it.
diff --git a/dev-util/dejagnu/metadata.xml b/dev-util/dejagnu/metadata.xml
new file mode 100644
index 000000000000..fb4199eb7afe
--- /dev/null
+++ b/dev-util/dejagnu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>toolchain</herd>
+</pkgmetadata>