summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 03:24:47 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:17:07 +0100
commit28eff152d8f4d440c4256317b625e08cc6a9bc66 (patch)
treea0e90477b30197a5194885e18b730fca1def65bd /dev-util/buildbot
parentdev-util/babeltrace: eutils-- (diff)
downloadgentoo-28eff152d8f4d440c4256317b625e08cc6a9bc66.tar.gz
gentoo-28eff152d8f4d440c4256317b625e08cc6a9bc66.tar.bz2
gentoo-28eff152d8f4d440c4256317b625e08cc6a9bc66.zip
dev-util/buildbot: drop superfluous dies
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/buildbot')
-rw-r--r--dev-util/buildbot/buildbot-2.10.0.ebuild6
-rw-r--r--dev-util/buildbot/buildbot-2.10.1.ebuild6
-rw-r--r--dev-util/buildbot/buildbot-2.8.2-r1.ebuild6
-rw-r--r--dev-util/buildbot/buildbot-2.8.4.ebuild8
-rw-r--r--dev-util/buildbot/buildbot-3.0.2.ebuild6
-rw-r--r--dev-util/buildbot/buildbot-9999.ebuild4
6 files changed, 18 insertions, 18 deletions
diff --git a/dev-util/buildbot/buildbot-2.10.0.ebuild b/dev-util/buildbot/buildbot-2.10.0.ebuild
index eb906ec82e1f..c7c1f74b4a1c 100644
--- a/dev-util/buildbot/buildbot-2.10.0.ebuild
+++ b/dev-util/buildbot/buildbot-2.10.0.ebuild
@@ -94,10 +94,10 @@ src_compile() {
# missing files, so skip building
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
- emake html || die "Docs generation failed"
- popd > /dev/null
+ emake html
+ popd > /dev/null || die
fi
}
diff --git a/dev-util/buildbot/buildbot-2.10.1.ebuild b/dev-util/buildbot/buildbot-2.10.1.ebuild
index eb906ec82e1f..c7c1f74b4a1c 100644
--- a/dev-util/buildbot/buildbot-2.10.1.ebuild
+++ b/dev-util/buildbot/buildbot-2.10.1.ebuild
@@ -94,10 +94,10 @@ src_compile() {
# missing files, so skip building
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
- emake html || die "Docs generation failed"
- popd > /dev/null
+ emake html
+ popd > /dev/null || die
fi
}
diff --git a/dev-util/buildbot/buildbot-2.8.2-r1.ebuild b/dev-util/buildbot/buildbot-2.8.2-r1.ebuild
index 293a54f89f28..b0700a3d10e5 100644
--- a/dev-util/buildbot/buildbot-2.8.2-r1.ebuild
+++ b/dev-util/buildbot/buildbot-2.8.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -98,10 +98,10 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
emake html
- popd > /dev/null
+ popd > /dev/null || die
fi
}
diff --git a/dev-util/buildbot/buildbot-2.8.4.ebuild b/dev-util/buildbot/buildbot-2.8.4.ebuild
index a36c9bb8123c..e9d0a330e1ec 100644
--- a/dev-util/buildbot/buildbot-2.8.4.ebuild
+++ b/dev-util/buildbot/buildbot-2.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -100,10 +100,10 @@ src_compile() {
# missing files, so skip building
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
- emake html || die "Docs generation failed"
- popd > /dev/null
+ emake html
+ popd > /dev/null || die
fi
}
diff --git a/dev-util/buildbot/buildbot-3.0.2.ebuild b/dev-util/buildbot/buildbot-3.0.2.ebuild
index b1793f4d15e5..36fb6b16cb7b 100644
--- a/dev-util/buildbot/buildbot-3.0.2.ebuild
+++ b/dev-util/buildbot/buildbot-3.0.2.ebuild
@@ -96,10 +96,10 @@ src_compile() {
# missing files, so skip building
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
- emake html || die "Docs generation failed"
- popd > /dev/null
+ emake html
+ popd > /dev/null || die
fi
}
diff --git a/dev-util/buildbot/buildbot-9999.ebuild b/dev-util/buildbot/buildbot-9999.ebuild
index 1d50c7e005f6..05d2cacd1c75 100644
--- a/dev-util/buildbot/buildbot-9999.ebuild
+++ b/dev-util/buildbot/buildbot-9999.ebuild
@@ -96,10 +96,10 @@ src_compile() {
if use doc; then
einfo "Generation of documentation"
- pushd docs > /dev/null
+ pushd docs > /dev/null || die
#'man' target is currently broken
emake html
- popd > /dev/null
+ popd > /dev/null || die
fi
}