summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:08:07 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-05-01 20:19:29 -0400
commitd0ccd5a042c88cf8bc15801bd5e281781ca0686e (patch)
tree29ac62e6be038a19f839ae9596a957bbac4b67b5 /dev-util/buildbot-www/buildbot-www-3.1.1.ebuild
parentdev-util/buildbot-pkg: Version bump to 3.1.1 (diff)
downloadgentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.tar.gz
gentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.tar.bz2
gentoo-d0ccd5a042c88cf8bc15801bd5e281781ca0686e.zip
dev-util/buildbot-www: Version bump to 3.1.1
sync KEYWORDS among the pkgs. Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-util/buildbot-www/buildbot-www-3.1.1.ebuild')
-rw-r--r--dev-util/buildbot-www/buildbot-www-3.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild b/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild
new file mode 100644
index 000000000000..34eaab6d6621
--- /dev/null
+++ b/dev-util/buildbot-www/buildbot-www-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+
+inherit distutils-r1
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
+HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"
+
+MY_PV="${PV/_p/.post}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ ~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"