summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-25 10:26:06 +0200
committerAaron Bauman <bman@gentoo.org>2019-02-26 23:30:34 -0500
commitcb4cd7feff3c370bae7a26034274efdc5c3caaa7 (patch)
tree7dc5ef8d7e7d58a2b9ffed3b384d522ce8456e94 /dev-util/btyacc
parentnet-analyzer/chaosreader: take maintainership (diff)
downloadgentoo-cb4cd7feff3c370bae7a26034274efdc5c3caaa7.tar.gz
gentoo-cb4cd7feff3c370bae7a26034274efdc5c3caaa7.tar.bz2
gentoo-cb4cd7feff3c370bae7a26034274efdc5c3caaa7.zip
dev-util/btyacc: EAPI7 revbump, improve ebuild
Closes: https://bugs.gentoo.org/664546 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/9692 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-util/btyacc')
-rw-r--r--dev-util/btyacc/btyacc-3.0-r3.ebuild43
-rw-r--r--dev-util/btyacc/files/btyacc-3.0-includes.patch4
-rw-r--r--dev-util/btyacc/files/btyacc-3.0-makefile.patch4
3 files changed, 47 insertions, 4 deletions
diff --git a/dev-util/btyacc/btyacc-3.0-r3.ebuild b/dev-util/btyacc/btyacc-3.0-r3.ebuild
new file mode 100644
index 000000000000..2de9c25574c0
--- /dev/null
+++ b/dev-util/btyacc/btyacc-3.0-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}-3-0"
+DESCRIPTION="Backtracking YACC - modified from Berkeley YACC"
+HOMEPAGE="http://www.siber.com/btyacc"
+SRC_URI="http://www.siber.com/btyacc/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-fbsd ~x86-linux ~ppc-macos ~x86-macos"
+
+S="${WORKDIR}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-includes.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ cp -av Makefile{,.orig} || die
+ default
+ # fix memory issue/glibc corruption
+ sed -i -e "s|len + 13|len + 14|" main.c || die "Could not fix main.c"
+ # Darwin doesn't do static binaries
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i -e 's/-static//' Makefile || die
+ fi
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin btyacc
+ dodoc README README.BYACC
+ newman manpage btyacc.1
+}
diff --git a/dev-util/btyacc/files/btyacc-3.0-includes.patch b/dev-util/btyacc/files/btyacc-3.0-includes.patch
index a03f58fa3865..e415574213eb 100644
--- a/dev-util/btyacc/files/btyacc-3.0-includes.patch
+++ b/dev-util/btyacc/files/btyacc-3.0-includes.patch
@@ -1,5 +1,5 @@
---- mstring.c
-+++ mstring.c
+--- a/mstring.c
++++ b/mstring.c
@@ -1,6 +1,7 @@
#include <stdlib.h>
#include <stdio.h>
diff --git a/dev-util/btyacc/files/btyacc-3.0-makefile.patch b/dev-util/btyacc/files/btyacc-3.0-makefile.patch
index 884b49f46b9d..60187256d1a0 100644
--- a/dev-util/btyacc/files/btyacc-3.0-makefile.patch
+++ b/dev-util/btyacc/files/btyacc-3.0-makefile.patch
@@ -1,7 +1,7 @@
Respect CC, append to CFLAGS (but not -g), append to LDFLAGS, use system LD -jer
---- Makefile.orig 1999-07-15 19:40:12.000000000 +0200
-+++ Makefile 2009-09-04 15:27:15.000000000 +0200
+--- a/Makefile 1999-07-15 19:40:12.000000000 +0200
++++ b/Makefile 2009-09-04 15:27:15.000000000 +0200
@@ -8,14 +8,13 @@
HDRS = defs.h mstring.h