summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-07-09 13:11:59 -0700
committerZac Medico <zmedico@gentoo.org>2017-07-09 13:11:59 -0700
commit761b048fb292a85f594c18be55ac8743556a6480 (patch)
tree03f55ba186f768c60642dc9640eb1bc276f39036 /dev-util/bazel/bazel-0.3.2.ebuild
parentdev-util/bazel: fix tools/examples install location for bug 624302, revbump t... (diff)
downloadgentoo-761b048fb292a85f594c18be55ac8743556a6480.tar.gz
gentoo-761b048fb292a85f594c18be55ac8743556a6480.tar.bz2
gentoo-761b048fb292a85f594c18be55ac8743556a6480.zip
dev-util/bazel: remove old versions
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-util/bazel/bazel-0.3.2.ebuild')
-rw-r--r--dev-util/bazel/bazel-0.3.2.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-util/bazel/bazel-0.3.2.ebuild b/dev-util/bazel/bazel-0.3.2.ebuild
deleted file mode 100644
index 60d5fc5ed595..000000000000
--- a/dev-util/bazel/bazel-0.3.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit bash-completion-r1 java-pkg-2
-
-DESCRIPTION="Bazel build system"
-HOMEPAGE="https://bazel.io/"
-SRC_URI="https://github.com/bazelbuild/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-# strip corrupts the bazel binary
-RESTRICT="strip"
-DEPEND="virtual/jdk:1.8"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- ./compile.sh || die
- # Use standalone strategy to deactivate the bazel sandbox, since it
- # conflicts with FEATURES=sandbox.
- echo "build --spawn_strategy=standalone --genrule_strategy=standalone" \
- > "${T}/bazelrc" || die
- output/bazel --bazelrc="${T}/bazelrc" build //scripts:bazel-complete.bash || die
-}
-
-src_install() {
- dobin output/bazel
- newbashcomp bazel-bin/scripts/bazel-complete.bash ${PN}
-}