summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-30 21:57:33 +1000
committerSam Jorna <wraeth@gentoo.org>2016-05-01 00:33:58 +1000
commit50d8d91f5889bdd4b664835067dbc56212b11333 (patch)
treef367fda4aee90cefb70637fb8ad638525d16845f /dev-util/bats/bats-0.4.0.ebuild
parenteclass/ros-catkin.eclass: use emake tests with nonfatal as nonfatal is still ... (diff)
downloadgentoo-50d8d91f5889bdd4b664835067dbc56212b11333.tar.gz
gentoo-50d8d91f5889bdd4b664835067dbc56212b11333.tar.bz2
gentoo-50d8d91f5889bdd4b664835067dbc56212b11333.zip
dev-util/bats: new package
Bats is a TAP-compliant testing framework for Bash. It provides a simple way to verify that the UNIX programs you write behave as expected. This has been added in order to support app-admin/yadm in bug 581118. Maintainer assigned to Espen H per request under Proxy Maintainers. Gentoo-bug: 581392 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/bats/bats-0.4.0.ebuild')
-rw-r--r--dev-util/bats/bats-0.4.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/bats/bats-0.4.0.ebuild b/dev-util/bats/bats-0.4.0.ebuild
new file mode 100644
index 000000000000..3fa4d97e3843
--- /dev/null
+++ b/dev-util/bats/bats-0.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="An automated testing system for bash"
+HOMEPAGE="https://github.com/sstephenson/bats/"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_test() {
+ bin/bats --tap test
+}
+
+src_install() {
+ einstalldocs
+
+ dobin libexec/*
+ doman man/bats.1 man/bats.7
+}