summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-08-14 09:19:29 -0500
committerMatthias Maier <tamiko@gentoo.org>2015-08-14 09:19:51 -0500
commitf573a07ea65bbbe518d0ce42e0f631630a36069b (patch)
tree15092fffc47de7b4aeeccc3b0bb978e8eb20063f /dev-util/astyle/files
parentsys-auth/consolekit: Make pm-utils optional (diff)
downloadgentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.tar.gz
gentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.tar.bz2
gentoo-f573a07ea65bbbe518d0ce42e0f631630a36069b.zip
dev-util/astyle: version bump to 2.05.1 (bug #530584)
This commit also updates the soname handling (no trailing .0 in soname any more). Special thanks to David Hallas for an initial ebuild update. Gentoo-Bug: 530584 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-util/astyle/files')
-rw-r--r--dev-util/astyle/files/astyle-2.05.1-build_system.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/astyle/files/astyle-2.05.1-build_system.patch b/dev-util/astyle/files/astyle-2.05.1-build_system.patch
new file mode 100644
index 000000000000..23554499c798
--- /dev/null
+++ b/dev-util/astyle/files/astyle-2.05.1-build_system.patch
@@ -0,0 +1,56 @@
+diff --git a/build/gcc/Makefile b/build/gcc/Makefile
+index b1af4c1..1dfa021 100755
+--- a/build/gcc/Makefile
++++ b/build/gcc/Makefile
+@@ -34,15 +34,15 @@ objdir = obj
+ ipath=$(prefix)/bin
+ CBASEFLAGS = -W -Wall -fno-rtti -fno-exceptions
+ JAVAINCS = -I$(JAVA_HOME)/include
+-CXX = g++
++CXX ?= g++
+ INSTALL=install -o $(USER) -g $(USER)
+
+ ##################################################
+
+ # define compile options for each build
+-ifdef CFLAGS
+- CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CFLAGS)
+- CFLAGSd = -g $(CBASEFLAGS) $(CFLAGS)
++ifdef CXXFLAGS
++ CFLAGSr = -DNDEBUG $(CBASEFLAGS) $(CXXFLAGS)
++ CFLAGSd = -g $(CBASEFLAGS) $(CXXFLAGS)
+ else
+ CFLAGSr = -DNDEBUG -O3 $(CBASEFLAGS)
+ CFLAGSd = -g $(CBASEFLAGS)
+@@ -134,13 +134,13 @@ astyled: $(OBJd)
+ shared: libastyle-2.05.1.so
+ libastyle-2.05.1.so: $(OBJs)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@ $(LDFLAGSr) -o $(bindir)/$@ $^
+ @ echo
+
+ shareddebug: libastyle-2.05.1d.so
+ libastyle-2.05.1d.so: $(OBJsd)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSd) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@ $(LDFLAGSr) -o $(bindir)/$@ $^
+ @ echo
+
+ static: libastyle.a
+@@ -158,13 +158,13 @@ libastyled.a: $(OBJad)
+ java: libastyle-2.05.1j.so
+ libastyle-2.05.1j.so: $(OBJsj)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSr) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@ $(LDFLAGSr) -o $(bindir)/$@ $^
+ @ echo
+
+ javadebug: libastyle-2.05.1jd.so
+ libastyle-2.05.1jd.so: $(OBJsjd)
+ @ mkdir -p $(bindir)
+- $(CXX) -shared $(LDFLAGSd) -o $(bindir)/$@ $^
++ $(CXX) -shared -Wl,-soname,$@ $(LDFLAGSr) -o $(bindir)/$@ $^
+ @ echo
+
+ all: release debug shared shareddebug static staticdebug