summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2023-11-29 23:26:56 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-01-31 14:54:23 +0200
commit8dfac48ada1416436f7c2e62f996d36f75f85001 (patch)
tree733c2892ae7a6ce8668aeb5a54a1e8fc47ac7e5c /dev-ruby
parentdev-ruby/google-protobuf: Bump version 3.24.4 (diff)
downloadgentoo-8dfac48ada1416436f7c2e62f996d36f75f85001.tar.gz
gentoo-8dfac48ada1416436f7c2e62f996d36f75f85001.tar.bz2
gentoo-8dfac48ada1416436f7c2e62f996d36f75f85001.zip
dev-ruby/grpc: Bump version 1.59.2
Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/grpc/Manifest1
-rw-r--r--dev-ruby/grpc/grpc-1.54.0.ebuild4
-rw-r--r--dev-ruby/grpc/grpc-1.59.2.ebuild31
3 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/grpc/Manifest b/dev-ruby/grpc/Manifest
index 2c5dae3cdbda..3bd8d43cd81d 100644
--- a/dev-ruby/grpc/Manifest
+++ b/dev-ruby/grpc/Manifest
@@ -1 +1,2 @@
DIST grpc-1.54.0.gem 6047232 BLAKE2B 66e48f27748867eb99464ecf659204a2e0f8c9ad9c998fe13dbf8daf159f928d54414d28f121ecb52f1cb8d277651f91b4259eecf9cca2836d25cacbcfe9ea3a SHA512 72e76223800078584151cf6a6833b4cb3cfc0fa0733b050b9ccf5180ef7250b26fc22d7bac52f636b5ada68723eb04f67f51d24aacf7dc1288333c7adab556d6
+DIST grpc-1.59.2.gem 6404096 BLAKE2B 6953d538cee06c1f8795ca7949c22dd60d9aa4c4aa51c8d92631b646929682089969db1d2f206cd2e4c1e3692803c2cef685edf22f6d7a2d20b79dc735c942bc SHA512 a624ddf60f5befe043cdcfa015f2541bdf5b67604f8dd51652dd13a9576673df624513048d9e591c54da6e8fa1b983e78f8ca79d301c089fca5be6f12722b827
diff --git a/dev-ruby/grpc/grpc-1.54.0.ebuild b/dev-ruby/grpc/grpc-1.54.0.ebuild
index 0bd2e080f8f7..934ddf075b4a 100644
--- a/dev-ruby/grpc/grpc-1.54.0.ebuild
+++ b/dev-ruby/grpc/grpc-1.54.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,7 +20,7 @@ IUSE=""
ruby_add_rdepend "
dev-ruby/googleapis-common-protos-types:1
- >=dev-ruby/google-protobuf-3.21:3
+ >=dev-ruby/google-protobuf-3.24.4
"
each_ruby_install() {
diff --git a/dev-ruby/grpc/grpc-1.59.2.ebuild b/dev-ruby/grpc/grpc-1.59.2.ebuild
new file mode 100644
index 000000000000..934ddf075b4a
--- /dev/null
+++ b/dev-ruby/grpc/grpc-1.59.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTENSIONS=(src/ruby/ext/grpc/extconf.rb)
+RUBY_FAKEGEM_EXTRAINSTALL="etc src"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Send RPCs from Ruby using GRPC"
+HOMEPAGE="https://github.com/grpc/grpc"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/googleapis-common-protos-types:1
+ >=dev-ruby/google-protobuf-3.24.4
+"
+
+each_ruby_install() {
+ # Remove all the "src" bits that are not needed
+ rm -rf src/core src/ruby/spec src/ruby/ext/grpc/{libs,objs} || die
+
+ each_fakegem_install
+}