summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-26 06:46:49 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-26 06:46:49 +0100
commit9f86206dfbd1bbd2a368e94a0e03da1fb7da6011 (patch)
treed16aa1ccd5d4505d1275a48e542a5eadf50fbe4f /dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
parentdev-ruby/vcr: add 5.1.0 (diff)
downloadgentoo-9f86206dfbd1bbd2a368e94a0e03da1fb7da6011.tar.gz
gentoo-9f86206dfbd1bbd2a368e94a0e03da1fb7da6011.tar.bz2
gentoo-9f86206dfbd1bbd2a368e94a0e03da1fb7da6011.zip
dev-ruby/will_paginate: add 3.3.0
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/will_paginate/will_paginate-3.3.0.ebuild')
-rw-r--r--dev-ruby/will_paginate/will_paginate-3.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild b/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
new file mode 100644
index 000000000000..3f25988e7abf
--- /dev/null
+++ b/dev-ruby/will_paginate/will_paginate-3.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Most awesome pagination solution for Ruby"
+HOMEPAGE="https://github.com/mislav/will_paginate/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove tests for unpackaged ORMs
+ rm -f spec/finders/{sequel,mongoid,data_mapper}* || die
+}
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rails
+ dev-ruby/mocha
+ )"