summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-14 08:41:47 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-14 08:43:50 +0100
commit6323a1dbf511848f0d6279360d2375bf7131820a (patch)
tree4ca8de411d2ff2864be954262e75acdfde072825 /dev-ruby/tilt
parentdev-db/mysql-workbench: drop obsolete gnome-keyring cmake option (diff)
downloadgentoo-6323a1dbf511848f0d6279360d2375bf7131820a.tar.gz
gentoo-6323a1dbf511848f0d6279360d2375bf7131820a.tar.bz2
gentoo-6323a1dbf511848f0d6279360d2375bf7131820a.zip
dev-ruby/tilt: add 2.0.9
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.0.9.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index d1cd8f8b1221..39209f830ef3 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,2 +1,3 @@
DIST tilt-2.0.5.gem 52224 BLAKE2B c3bcd3cbf45ec3cd7669e5f3adb97f26508b5fc57fa234af8074422f7de62be8fca960d94a9b637b8adf8825b7b31cb5049b48bf75c08565b4ba42e2d37b3493 SHA512 b032439d00e09d3968b20f5ea5937c5918b1e10e0255cce402b6859b7d59ecdc265523a151c0fcca0034e0de26ca5fe422944790939896d7e0000641980764fa
DIST tilt-2.0.8.gem 54784 BLAKE2B 14b067227a1c81060b4627d39fadcae00300fa30c3b4741c2c07f0e69bbe62b1f1e8f3a165f43ff72c9788d3621a133375c3be72c9bf16f0c18686f550bc3c16 SHA512 1767f2e5ce45afe95d84d32de7c2b6fe24ff7cb6f7ee8485d84344820b2f6e969ae60a6fbaa7141f7fe135c6540d96fa5b27fd8010b95c0ded5d049a315001d5
+DIST tilt-2.0.9.gem 55296 BLAKE2B dd181295d2317ef591e9b89a0a4cf29680a05403c89c33680f563459ebbfc675bfaef14c864f8c8834103fc2ea069b33dc928f2b804d911eec21b09427f7c619 SHA512 522b2b40ca1eefc7df66cb421c66734699a2ffb1e7d1797181c2718f7ca018d3376c1a2b3617b5d3549115af69108db4c3c4632e2682329d5baf24bfdae92b42
diff --git a/dev-ruby/tilt/tilt-2.0.9.ebuild b/dev-ruby/tilt/tilt-2.0.9.ebuild
new file mode 100644
index 000000000000..efb26b7ad062
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.9.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/bluecloth
+ dev-ruby/coffee-script
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+ !!<dev-ruby/maruku-0.7.2 )"
+
+ruby_add_rdepend "!!<dev-ruby/tilt-1.4.1-r2:0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+}