summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-16 09:19:38 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-16 09:20:05 +0200
commit004b6db38aff3ceca3002bf677f87552e44fcd95 (patch)
tree89ea57b83297b5b0df53898c56607213c9dc535d /dev-ruby/test-unit
parentdev-python/traits: Enable python3.6 (tests pass) (diff)
downloadgentoo-004b6db38aff3ceca3002bf677f87552e44fcd95.tar.gz
gentoo-004b6db38aff3ceca3002bf677f87552e44fcd95.tar.bz2
gentoo-004b6db38aff3ceca3002bf677f87552e44fcd95.zip
dev-ruby/test-unit: build docs with rdoc instead of yard, bug 614486
Build docs with rdoc instead of yard, because yard requires a lot of dependencies. For new ruby versions it will take too much time to mark all of them as compatible. We hacked around this by hoping no ruby version was eselected where yard was not compatible. By depending on rdoc to build the docs the dependencies are self-contained in the initial set of ebuilds for a new ruby version. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/test-unit-3.2.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/test-unit-3.2.3-r1.ebuild b/dev-ruby/test-unit/test-unit-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..c6a6237135e7
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.2.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+
+LICENSE="|| ( Ruby GPL-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_prepare() {
+ mv doc doc-install || die "moving doc directory out of the way failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}