summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-19 08:25:58 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-19 08:25:58 +0100
commit6b556f51e73af10e3938e9e7a40c9edfe9cae788 (patch)
tree51f2893f6b188036e82ff3121e8a4ac691ce3a4c /dev-ruby/rubyntlm
parentdev-ruby/io-event: drop 1.1.2, 1.1.3, 1.1.4 (diff)
downloadgentoo-6b556f51e73af10e3938e9e7a40c9edfe9cae788.tar.gz
gentoo-6b556f51e73af10e3938e9e7a40c9edfe9cae788.tar.bz2
gentoo-6b556f51e73af10e3938e9e7a40c9edfe9cae788.zip
dev-ruby/rubyntlm: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rubyntlm')
-rw-r--r--dev-ruby/rubyntlm/rubyntlm-0.6.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/rubyntlm/rubyntlm-0.6.3-r1.ebuild b/dev-ruby/rubyntlm/rubyntlm-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..072610e07317
--- /dev/null
+++ b/dev-ruby/rubyntlm/rubyntlm-0.6.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby/NTLM provides message creator and parser for the NTLM authentication"
+HOMEPAGE="https://github.com/winrb/rubyntlm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+}