summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-06 07:56:27 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-06 07:56:27 +0100
commit9ce481886dd7c568fa0fd90fc92070a8bae34caa (patch)
tree9cfb2c466ddcee70552cbc860dc5ff8b0d54caf2 /dev-ruby/propshaft
parentdev-ruby/kramdown: enable ruby31 (diff)
downloadgentoo-9ce481886dd7c568fa0fd90fc92070a8bae34caa.tar.gz
gentoo-9ce481886dd7c568fa0fd90fc92070a8bae34caa.tar.bz2
gentoo-9ce481886dd7c568fa0fd90fc92070a8bae34caa.zip
dev-ruby/propshaft: add 0.7.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/propshaft')
-rw-r--r--dev-ruby/propshaft/Manifest1
-rw-r--r--dev-ruby/propshaft/propshaft-0.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/propshaft/Manifest b/dev-ruby/propshaft/Manifest
index a8b03693e954..efd6211c09ed 100644
--- a/dev-ruby/propshaft/Manifest
+++ b/dev-ruby/propshaft/Manifest
@@ -1,2 +1,3 @@
DIST propshaft-0.6.1-git.tgz 245087 BLAKE2B 6e04ebc0315c263f79dbfc9f836b270b8b693e1a7e332a97d8abe5cc6555d0acc9efe3ae7979c901ca2c502460e8ee67b83420863d5dabdf50fbc2028aacd5b9 SHA512 35600b7e051810c7f0798f29faab7c7bcabf04198fc56ee9a4492d18ddfabf543cfbf11c28f35eb5e2a64eb57c65b95567e00441852ac0f29d8538ad8d5cb1b4
DIST propshaft-0.6.4-git.tgz 245384 BLAKE2B 8089c7ee8f8d41f761a31bcd4751899da86302cdf7e1d5a9ba673e8a64431b0e35bbfa7d09fb0caa5ca06457b7134f27c3f37ade213922d616b374adac9824c5 SHA512 3302e1a0ef4bd47094566b393db77f1181e3e3b67c08b18694cea48b4518a45893dc16238ce1d86965d0b37894069ddbe7040392e7cdcad5caa80d7ff86bf2eb
+DIST propshaft-0.7.0-git.tgz 247111 BLAKE2B aecf4dcab9b57f1933e8f7066f4b229348cf60e4104cc82e14edb945e797a263012fe5b7b65de8ff0165e652256a0bd8fba24af8f08d8e9391050e36e56d5f31 SHA512 3d6dba7a3b5b522f3e4a9f43dc6b9981fbb475374be0b90c8abb2f19c587d025b58876ddb6a9e1b9992e3f357a96b50b6138173d10b8ae131e9457309b8cc0c9
diff --git a/dev-ruby/propshaft/propshaft-0.7.0.ebuild b/dev-ruby/propshaft/propshaft-0.7.0.ebuild
new file mode 100644
index 000000000000..6f3faa84c6cc
--- /dev/null
+++ b/dev-ruby/propshaft/propshaft-0.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="propshaft.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Deliver assets for Rails"
+HOMEPAGE="https://github.com/rails/propshaft"
+SRC_URI="https://github.com/rails/propshaft/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~ppc64 ~riscv"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-7.0.0:*
+ >=dev-ruby/activesupport-7.0.0:*
+ dev-ruby/rack:*
+ >=dev-ruby/railties-7.0.0:*
+"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-7.0.0 )"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+ sed -i -e '/debug/ s:^:#:' Gemfile || die
+
+ sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}