summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-09-08 09:44:11 +0200
committerHans de Graaff <graaff@gentoo.org>2022-09-08 09:45:23 +0200
commitc537ab7d9ca6875db88415c08004f9cb176f79f0 (patch)
tree61e92402ee7ec0353125314d3b146884d1d2be5c /dev-ruby/multipart-post
parentmail-client/thunderbird-bin: add 102.2.2, drop 102.2.1 (diff)
downloadgentoo-c537ab7d9ca6875db88415c08004f9cb176f79f0.tar.gz
gentoo-c537ab7d9ca6875db88415c08004f9cb176f79f0.tar.bz2
gentoo-c537ab7d9ca6875db88415c08004f9cb176f79f0.zip
dev-ruby/multipart-post: avoid developer-oriented warnings
These warnings are aimed at developers using this code but they are not actionable for people consuming this package as part of an existing tool. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/multipart-post')
-rw-r--r--dev-ruby/multipart-post/multipart-post-2.2.3-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/multipart-post/multipart-post-2.2.3-r1.ebuild b/dev-ruby/multipart-post/multipart-post-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..fdf3a83ed1f7
--- /dev/null
+++ b/dev-ruby/multipart-post/multipart-post-2.2.3-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="multipart-post.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds a streamy multipart form post capability to Net::HTTP"
+HOMEPAGE="https://github.com/socketry/multipart-post"
+SRC_URI="https://github.com/socketry/multipart-post/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's:_relative ":"./:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove warnings since these are only actionable for developers,
+ # not for people consuming this package as part of other tools.
+ sed -i -e '/Top level/ s/warn/# warn/' lib/*.rb || die
+}