summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-01 10:54:06 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-01 10:54:21 +0200
commit44559db2f2b9874956333c81d7750069d3cf9a30 (patch)
tree5351ec04cdffd5d128d12d1563a4695fb538d663 /dev-ruby/cliver
parentdev-ruby/rspec-support: drop 3.10.2, 3.10.3 (diff)
downloadgentoo-44559db2f2b9874956333c81d7750069d3cf9a30.tar.gz
gentoo-44559db2f2b9874956333c81d7750069d3cf9a30.tar.bz2
gentoo-44559db2f2b9874956333c81d7750069d3cf9a30.zip
dev-ruby/cliver: update EAPI 7 -> 8, add ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/cliver')
-rw-r--r--dev-ruby/cliver/cliver-0.3.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/cliver/cliver-0.3.2-r2.ebuild b/dev-ruby/cliver/cliver-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..9c8ea9218e07
--- /dev/null
+++ b/dev-ruby/cliver/cliver-0.3.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="cliver.gemspec"
+
+inherit ruby-fakegem
+
+COMMIT=3d72e99af19c273a3f88adcd4b96c4b65b1b6d4b
+
+DESCRIPTION="An easy way to detect and use command-line dependencies"
+HOMEPAGE="https://yaauie.github.io/cliver/"
+SRC_URI="https://github.com/yaauie/cliver/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="cliver-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
+}