summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-24 09:30:25 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-24 09:36:24 +0200
commitcceeefb46530672199d4a01d7ff0e97b2f3e401b (patch)
tree03a8b0883b0880afb244b69ccd141572b70b270a /dev-ruby/activemodel/activemodel-6.0.0.ebuild
parentdev-ruby/rails-html-sanitizer: add 1.2.0 (diff)
downloadgentoo-cceeefb46530672199d4a01d7ff0e97b2f3e401b.tar.gz
gentoo-cceeefb46530672199d4a01d7ff0e97b2f3e401b.tar.bz2
gentoo-cceeefb46530672199d4a01d7ff0e97b2f3e401b.zip
dev-ruby/activemodel: add 6.0.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activemodel/activemodel-6.0.0.ebuild')
-rw-r--r--dev-ruby/activemodel/activemodel-6.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/activemodel-6.0.0.ebuild b/dev-ruby/activemodel/activemodel-6.0.0.ebuild
new file mode 100644
index 000000000000..3c147647fc66
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-6.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Toolkit for building modeling frameworks like Active Record and Active Resource"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}:*
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ dev-ruby/test-unit:2
+ dev-ruby/mocha
+ >=dev-ruby/bcrypt-ruby-3.1.7
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}