summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-03-08 15:47:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2022-03-08 17:16:42 +0100
commit5fe8c05a570d1eb33c287b06678160fd57ce6ba4 (patch)
tree3f26bfc7c3ea264bfdf7b34e8eb3aad484e78c3e /dev-ros/topic_tools
parentdev-ros/rostopic: Bump to 1.15.14. (diff)
downloadgentoo-5fe8c05a570d1eb33c287b06678160fd57ce6ba4.tar.gz
gentoo-5fe8c05a570d1eb33c287b06678160fd57ce6ba4.tar.bz2
gentoo-5fe8c05a570d1eb33c287b06678160fd57ce6ba4.zip
dev-ros/topic_tools: Bump to 1.15.14.
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/topic_tools')
-rw-r--r--dev-ros/topic_tools/Manifest1
-rw-r--r--dev-ros/topic_tools/topic_tools-1.15.14.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/topic_tools/Manifest b/dev-ros/topic_tools/Manifest
index 9a010b111286..fa82ade78482 100644
--- a/dev-ros/topic_tools/Manifest
+++ b/dev-ros/topic_tools/Manifest
@@ -1,2 +1,3 @@
DIST ros_comm-1.15.11.tar.gz 1089801 BLAKE2B 2ff05aa249dbdf5af2704efb52ef3fa12681e277f5e4fd0024645350bace6e41d3430ea727bc0d0e47ac1f946d8ef0b6b0c30e99a3695d67fd863bf9e01a8b3d SHA512 b8033ac96ebcd6a93c107dadd31b13fc48aab4cf2be9ebed0f773f94514b13cc395971eba9142aeb830251db7dd3df8a82d201b5663e9e1461b2ca792c981c99
DIST ros_comm-1.15.13.tar.gz 1093884 BLAKE2B f92b3bc0b441f4440e0ddd69527b79943130e5eb37c0071ea3b8fe26408490a5c9ac7c2ace1e83ad4d6dbaff78600ef399166b72d29eb1c6c0082a7db3295054 SHA512 f5ca51da01c557c4f7a00216b9a39d2d891666c50bd17e0c9add65047e2693a178280488121e72a1a756a2e17f67172e817b792e359ab42dd8d6bd44dec16166
+DIST ros_comm-1.15.14.tar.gz 1094270 BLAKE2B 3b40e23f361e7f7939a9015f22956c1631e25b21d5f76eaff82cb08b378aa3733ed296bef7cdc148ae7d12e6a8dae8216bc7f230e15233bff1dec9172a25cafe SHA512 e16294eb5341669550513a6f13fa3f9f276b7f41a7a7b0cf30e6d64783464ce445d3cf0466dc41ef249f90452910741212de3c37fdff221426698a299fc32501
diff --git a/dev-ros/topic_tools/topic_tools-1.15.14.ebuild b/dev-ros/topic_tools/topic_tools-1.15.14.ebuild
new file mode 100644
index 000000000000..e11896922fa9
--- /dev/null
+++ b/dev-ros/topic_tools/topic_tools-1.15.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=tools/${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbash[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_SINGLE_USEDEP}]
+ dev-cpp/gtest
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ )"