summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-21 16:25:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-21 16:51:30 +0100
commit091bdd6c03c37a1b8b2065d877977125ac916270 (patch)
treea9b093fb12c611cfe18d7ada00a583e4b0e112eb /dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild
parentdev-ros/rosapi: Bump to 0.10.1. (diff)
downloadgentoo-091bdd6c03c37a1b8b2065d877977125ac916270.tar.gz
gentoo-091bdd6c03c37a1b8b2065d877977125ac916270.tar.bz2
gentoo-091bdd6c03c37a1b8b2065d877977125ac916270.zip
dev-ros/rosbridge_library: Bump to 0.10.1.
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild')
-rw-r--r--dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild b/dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild
new file mode 100644
index 000000000000..9ebd079262d5
--- /dev/null
+++ b/dev-ros/rosbridge_library/rosbridge_library-0.10.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Core rosbridge package responsible for interpreting JSON and performing the appropriate ROS action"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pymongo[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/cbor[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy_tutorials[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"