summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-02 13:13:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-05 11:52:08 +0200
commitc0cf21c5c2252bdd31946ca665b9dac62f6b928e (patch)
tree7e30bbcdec5d3874e5c32e7e8e51fcca5396e839 /dev-ros/rosbag_storage
parentdev-ros/rosbag: Bump to 1.15.10. (diff)
downloadgentoo-c0cf21c5c2252bdd31946ca665b9dac62f6b928e.tar.gz
gentoo-c0cf21c5c2252bdd31946ca665b9dac62f6b928e.tar.bz2
gentoo-c0cf21c5c2252bdd31946ca665b9dac62f6b928e.zip
dev-ros/rosbag_storage: Bump to 1.15.10.
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbag_storage')
-rw-r--r--dev-ros/rosbag_storage/Manifest1
-rw-r--r--dev-ros/rosbag_storage/rosbag_storage-1.15.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/rosbag_storage/Manifest b/dev-ros/rosbag_storage/Manifest
index fd3eb70a996d..06f95139f2ab 100644
--- a/dev-ros/rosbag_storage/Manifest
+++ b/dev-ros/rosbag_storage/Manifest
@@ -1,2 +1,3 @@
+DIST ros_comm-1.15.10.tar.gz 1089479 BLAKE2B 9855089aeb608466c3bff22676093c172e1e7898a1c1d7ab35cfffb948df4cb1324abbfc6c209df5944bee6265f24c53250c9bb0f811394bf276e33c19e81ee2 SHA512 34ac32a16eb170dae683e97dbc1528e1f0b2c3ddab9a84f2690ba92aa66639e0c99902ebc2e8e3e1aa5d6c97e6bd3d925f34827aa1943c3213eae2d211baf5a8
DIST ros_comm-1.15.8.tar.gz 1080826 BLAKE2B c1a1e085225a96cf0b50309cb78e1ccdabefce1f23ee669393b7fc747537c7e39bfb6ad382b0d24e3b5507b1d0f3eaf2051a1bee90507b0e724e06a83df301a2 SHA512 b1c34ab6548400fc014eda496e5d1e1c7d134b9062a031386ac4eac3245ca83b034f74f0a189ccf9ec6933c18d6df0ae1a93d05f1526d09debf70c25aa25b6b9
DIST ros_comm-1.15.9.tar.gz 1087337 BLAKE2B 8c1582425770eee7898de42785c620c5fe82e31764d8947c16f9dbb43dd03d0201344e72d5a24911f7cc3cf4eacd51d6fc2940cc2346b635a2c769b055898297 SHA512 3f009a29d74dd74169585afb8d08c41faa19128e384ef6aa6c7bf58ae4d31345e4ea5441fc99a81b7742f724df7c7e3c16c4e51473c4fddeb4b9b6bf41cff04b
diff --git a/dev-ros/rosbag_storage/rosbag_storage-1.15.10.ebuild b/dev-ros/rosbag_storage/rosbag_storage-1.15.10.ebuild
new file mode 100644
index 000000000000..98d1abfadea8
--- /dev/null
+++ b/dev-ros/rosbag_storage/rosbag_storage-1.15.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back ROS message"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/console_bridge
+
+ dev-ros/cpp_common
+ >=dev-ros/pluginlib-1.13.0-r2:=
+ dev-ros/roscpp_serialization
+ dev-ros/roscpp_traits
+ dev-ros/rostime
+ dev-ros/roslz4
+
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-libs/console_bridge:=
+ dev-libs/tinyxml2:=
+
+ dev-libs/openssl:0=
+ app-crypt/gpgme
+"
+DEPEND="${RDEPEND}
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rostest
+ dev-cpp/gtest
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ export CATKIN_PREFIX_PATH="${BUILD_DIR}/devel/:${CATKIN_PREFIX_PATH}"
+ ros-catkin_src_test
+}