summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:43:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:40 +0200
commitba41c68ee3aaa18a48ff1396929129692b8011a1 (patch)
tree9d17d7c584a7258fd93a7f954a8cbc979f7e1ed4 /dev-ros/geodesy
parentdev-ros/geodesy: bump eapi (diff)
downloadgentoo-ba41c68ee3aaa18a48ff1396929129692b8011a1.tar.gz
gentoo-ba41c68ee3aaa18a48ff1396929129692b8011a1.tar.bz2
gentoo-ba41c68ee3aaa18a48ff1396929129692b8011a1.zip
dev-ros/geodesy: Bump to 0.5.5.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/geodesy')
-rw-r--r--dev-ros/geodesy/Manifest1
-rw-r--r--dev-ros/geodesy/geodesy-0.5.5.ebuild34
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild1
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
index 25044fdda2f9..5a8dd199ded3 100644
--- a/dev-ros/geodesy/Manifest
+++ b/dev-ros/geodesy/Manifest
@@ -1,2 +1,3 @@
DIST geographic_info-0.5.2.tar.gz 27336 BLAKE2B f864d8b70b5b0d797cec81e25a25d0dd708bcc49c169f68216616d900b1d11918583f6f5ec4a919ad03b08ee86b2a36cde575c1054c58a93974d4c4faf6e2aae SHA512 8b512399ef61ebfb9816c613ed4fcde23ec52a9b4bbd1bb7268c8ec7fe03b1a157435fef17b8af72fdf88ce6ed0b9130473183402e0875a25eac0ac46df0d00d
DIST geographic_info-0.5.3.tar.gz 27446 BLAKE2B 51463f872829224c618b1d37c3d07ba53ee00b4f3e48bbc202d9ab4abfe8db8148dbbfdb6780af5aaf36ab9e9a7dca973b603a22139a192a96f6bcef87fa52a5 SHA512 681aad5ba62363cf96255351e884c8ba8d3110571e6e97c9340f8d15f38183900c2a04e109416b4113a0a042ebd9cdb8fe075c507200dac06052b444f4212ab3
+DIST geographic_info-0.5.5.tar.gz 27762 BLAKE2B 9235911d6a2b010e47722268f5aa14b2bd10dac73bf4445bcd6585c5094947e9ea43ee2ccb6d6a3b0ae788d149fcc546e6618f0097e4bde32d69ed9baacbf255 SHA512 a1699778cd85960603435e7b7d46831c7c5ac4b57f4a06e9f394933799151a5ebf95c59bc109ca05eeb9376763aae8c77bc9150081c81170f1778730145910ec
diff --git a/dev-ros/geodesy/geodesy-0.5.5.ebuild b/dev-ros/geodesy/geodesy-0.5.5.ebuild
new file mode 100644
index 000000000000..359c415f7f2f
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
index 2bec79ff97f9..359c415f7f2f 100644
--- a/dev-ros/geodesy/geodesy-9999.ebuild
+++ b/dev-ros/geodesy/geodesy-9999.ebuild
@@ -3,7 +3,6 @@
EAPI=7
ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
-VER_PREFIX=geographic_info-
KEYWORDS="~amd64"
ROS_SUBDIR=${PN}