summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-20 10:50:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-20 11:01:08 +0100
commitfd8e9a8acb5a3db96f416ff50eddb94b9550ef86 (patch)
treee3896ff3b0c4bce059d3917ff8662e0e44e60f1f /dev-qt
parentsys-kernel/vanilla-sources: Linux version bumps (diff)
downloadgentoo-fd8e9a8acb5a3db96f416ff50eddb94b9550ef86.tar.gz
gentoo-fd8e9a8acb5a3db96f416ff50eddb94b9550ef86.tar.bz2
gentoo-fd8e9a8acb5a3db96f416ff50eddb94b9550ef86.zip
dev-qt/qtwayland: 5.15.2-r18 version bump at 4644d51f
Adrien Faveraux (1): Move the wayland socket polling to a separate event thread Elvis Lee (2): Handle registry_global out of constructor Connect flushRequest after forceRoundTrip Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r18.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index abf1cb63eafc..343c801c49a2 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
+DIST qtwayland-5.15.2-4644d51f.tar.gz 831697 BLAKE2B c3d60416ef71030018918ec5157122e2585d270d5aa1a74d66874a33f14f0c4ac85da5a1dd7bfb422a1090f79e5d2c08763c68fe724416b34bad16f945d1740c SHA512 e350396e9bdfa6f0fda938af74c722792d50473eb3d786442ba11919e7801f0cd8d045916c8e49d8a63ffd966376cb74e7cc1c3d4d1732e71061fb8343a497d3
DIST qtwayland-5.15.2-867540b9.tar.gz 830061 BLAKE2B b831288d6a3e671631b4df00eb1edb72e35128f3ed5a73983b3e15193f554fddcd0337deb832d44b795d2e37f0601fe35b8b0fcb5986bcc44154d172f3a54193 SHA512 b834802811d9f65559ef5e7468189b53c666e390aa09edeb490e5fee2dece13082b11da0f8b5924b89f7dc8e1eba375a485940f4dfbf0445f3d1e96033e33f24
DIST qtwayland-5.15.2-eb422ab5.tar.gz 829140 BLAKE2B e913e481741b23873a88db32896c7f3445a2ddee2dc9cfdf8e132fdd79021de369506e32ce9ed50977fb1c42d624169b7d67c9247f7609276e699e5ab3a9462e SHA512 b5094b00feab5909b4de6382a3633fc321d5f5fbc34e4cbde1f364123b24990df95cef5c34a90f73dca67b0578e0da71b894f771ebbd8d152dcdc71b114d9773
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r18.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r18.ebuild
new file mode 100644
index 000000000000..48fffae55af5
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2-r18.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_COMMIT=4644d51f4b52e83fc1b4d02b380d80d9d57e76fa
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+SLOT=5/${QT5_PV} # bug 815646
+IUSE="vulkan X"
+
+DEPEND="
+ dev-libs/wayland
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ =dev-qt/qtdeclarative-${QT5_PV}*:5=
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
+ media-libs/libglvnd
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}