summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-27 03:09:25 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-27 03:25:52 -0400
commitf55a347d05dae45f435cf7399e992e10c10890d6 (patch)
tree06056a9aa1124050c5fa7fbefd0bfc1645a9aec2 /dev-qt
parentdev-qt/qtvirtualkeyboard: add 6.7.3 (diff)
downloadgentoo-f55a347d05dae45f435cf7399e992e10c10890d6.tar.gz
gentoo-f55a347d05dae45f435cf7399e992e10c10890d6.tar.bz2
gentoo-f55a347d05dae45f435cf7399e992e10c10890d6.zip
dev-qt/qtwayland: add 6.7.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-6.7.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 5d43957c45b9..ff35070d4b3e 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,4 +1,5 @@
DIST qtwayland-5.15.14-gentoo-kde-1.tar.xz 47472 BLAKE2B 3812e5f18bcb857cf3c76cf8a53525a84b14bc4cf8430f4339c1ef9a5d6208dcdfba3f052bcc80c6ad8815db2415207e2eb5ed07bbf9e7076be675f2a4cee3c0 SHA512 912bc902e4f9d945dac396c75a2af9896e3002535a51e6b5b07166c38b9d6ea073da3d93db07742a0db295dd5f8167fdef351230adcb2145704c36b576c0f5e3
DIST qtwayland-everywhere-opensource-src-5.15.14.tar.xz 560916 BLAKE2B a5edb21446348f20e6f65736b402c3075a4bde0d7fa02c24cbfc5de65739ca8d7ac2186bd17a995bfb3de23106e696e2b1321dc3ae401984bdafaa3479c9aa1e SHA512 9e8add52353f7a146759511c49c001cd76a56790a81af5222f6f2d3d1a2f1ee9cc62048c72efe69708eb3444c6115272d4af8d738df7b1e1da959359d7420dbb
DIST qtwayland-everywhere-src-6.7.2.tar.xz 1123220 BLAKE2B 70c2d8942afc4e1629d2ef34b6c062ecb5800185bb37e150c1d66a5216606028d2f59668991bddb5036572c962e92c3658d336167a7f9ffbf3d2f4d609a771f9 SHA512 2cd4f45f05ae60bc7f82b94f2e9c217ee4b8322f60381e1b079b90e0687e51cfbeb10b5dd724e1cca7e422b1b101d2b91c0ee47b1a732411cef330fb052c97c2
+DIST qtwayland-everywhere-src-6.7.3.tar.xz 1123508 BLAKE2B 39cd8c7d2486318d3eb4351dc0e4e6a2c37e0aeb9727e2715accfec7ba2710288c251fdd5d6a71ba11c065509f7312c194a8e2b757d484ec1734270044e0d7aa SHA512 9e15f3798ae7738b69e367343ffd7992fcdaebeffbcb10414fe2f24be553ca63e5504ef0a8405348702d0581dabebd1c2360728f63757c7445900b04df5e9ad7
DIST qtwayland-everywhere-src-6.8.0-rc.tar.xz 1133748 BLAKE2B 0d5b468f303be8fe892695adf77b6c015429bbea6051f8a834a003495e9be3b2a0d2d2b06ab9ddee2817e616715426d47c5f11b46ef2bb70d4b436cea2353666 SHA512 3c1b4a4ee85e5ad9f1528311ca3a63be85abbccf2c6dd59f089e7834f31a6a6734e997ab78ce2e161053edc3899054e5d752ae187d1f805e3be83d72244af084
diff --git a/dev-qt/qtwayland/qtwayland-6.7.3.ebuild b/dev-qt/qtwayland/qtwayland-6.7.3.ebuild
new file mode 100644
index 000000000000..11f94d7bd709
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-6.7.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+IUSE="accessibility compositor qml vulkan"
+
+RDEPEND="
+ dev-libs/wayland
+ ~dev-qt/qtbase-${PV}:6[accessibility=,gui,opengl,vulkan=,wayland]
+ media-libs/libglvnd
+ x11-libs/libxkbcommon
+ compositor? (
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+"
+BDEPEND="dev-util/wayland-scanner"
+
+CMAKE_SKIP_TESTS=(
+ # segfaults for not-looked-into reasons, but not considered
+ # an issue given >=seatv5 exists since wayland-1.10 (2016)
+ tst_seatv4
+ # needs a compositor/opengl, skip the extra trouble
+ tst_surface
+ tst_xdgdecorationv1
+ # known failing with wayland-1.23.0 (or at least with offscreen), not
+ # believed to result in critical runtime issues so skip until this is
+ # looked at upstream (https://bugreports.qt.io/browse/QTBUG-126379)
+ tst_client
+ tst_compositor
+ tst_scaling
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Quick)
+ $(qt_feature compositor wayland_server)
+ )
+
+ qt6-build_src_configure
+}
+
+src_test() {
+ # users' session setting may break tst_clientextension (bug #927030)
+ unset DESKTOP_SESSION XDG_CURRENT_DESKTOP
+ unset GNOME_DESKTOP_SESSION_ID KDE_FULL_SESSION
+
+ qt6-build_src_test
+}