summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-25 15:55:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:08 -0400
commit1c1c5f921cb4b20a53a31b6353a4d456881bb6a0 (patch)
tree778a1fc3a07bc3409246e6f30eb87ebc8260004d /dev-qt/qtbase
parentdev-qt/qtbase: refactor use/dependences handling (diff)
downloadgentoo-1c1c5f921cb4b20a53a31b6353a4d456881bb6a0.tar.gz
gentoo-1c1c5f921cb4b20a53a31b6353a4d456881bb6a0.tar.bz2
gentoo-1c1c5f921cb4b20a53a31b6353a4d456881bb6a0.zip
dev-qt/qtbase: decouple qttest from USE=gui, enable by default
Been finding this kind of confusing, and having every ebuilds that run tests depend on [gui] does not seem right, and also prevent doing minimalist tests to find issues. This leaves two option: 1. IUSE="+testlib" 2. enable unconditionally 1 seems sane, but it's not that unusual that revdeps need qttest for building (even if not running tests, see packages depending on dev-qt/qttest:5 without 'test?'). qtdeclarative also fails without it last I know of, meaning most people would need it. And then qttest has a rather small footprint, rather than hunt what needs it or not it seems simpler to just always have it (embedded edge cases can still use MYCMAKEARGS or INSTALL_MASK). Skipping revbump given was already done once in this commit batch. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.2-r1.ebuild7
-rw-r--r--dev-qt/qtbase/qtbase-6.5.9999.ebuild7
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild7
3 files changed, 6 insertions, 15 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild b/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
index cadf0551b78f..3dec9dea132a 100644
--- a/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.2-r1.ebuild
@@ -39,10 +39,7 @@ REQUIRED_USE="
gui? ( || ( X eglfs wayland ) )
libinput? ( udev )
sql? ( || ( ${QT6_IUSE[sql]//+/} ) )
- test? (
- gui icu
- sql? ( sqlite )
- )
+ test? ( icu sql? ( sqlite ) )
"
# groups:
@@ -173,9 +170,9 @@ src_configure() {
$(qt_feature concurrent)
$(qt_feature dbus)
$(qt_feature gui)
- $(qt_feature gui testlib) # shared w/ gui
$(qt_feature network)
$(qt_feature sql)
+ -DQT_FEATURE_testlib=ON # trivial and often needed to build revdeps
$(qt_feature xml)
)
diff --git a/dev-qt/qtbase/qtbase-6.5.9999.ebuild b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
index 4f0ba7ab377b..32bec5120cca 100644
--- a/dev-qt/qtbase/qtbase-6.5.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
@@ -39,10 +39,7 @@ REQUIRED_USE="
gui? ( || ( X eglfs wayland ) )
libinput? ( udev )
sql? ( || ( ${QT6_IUSE[sql]//+/} ) )
- test? (
- gui icu
- sql? ( sqlite )
- )
+ test? ( icu sql? ( sqlite ) )
"
# groups:
@@ -168,9 +165,9 @@ src_configure() {
$(qt_feature concurrent)
$(qt_feature dbus)
$(qt_feature gui)
- $(qt_feature gui testlib) # shared w/ gui
$(qt_feature network)
$(qt_feature sql)
+ -DQT_FEATURE_testlib=ON # trivial and often needed to build revdeps
$(qt_feature xml)
)
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index 4f0ba7ab377b..32bec5120cca 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -39,10 +39,7 @@ REQUIRED_USE="
gui? ( || ( X eglfs wayland ) )
libinput? ( udev )
sql? ( || ( ${QT6_IUSE[sql]//+/} ) )
- test? (
- gui icu
- sql? ( sqlite )
- )
+ test? ( icu sql? ( sqlite ) )
"
# groups:
@@ -168,9 +165,9 @@ src_configure() {
$(qt_feature concurrent)
$(qt_feature dbus)
$(qt_feature gui)
- $(qt_feature gui testlib) # shared w/ gui
$(qt_feature network)
$(qt_feature sql)
+ -DQT_FEATURE_testlib=ON # trivial and often needed to build revdeps
$(qt_feature xml)
)