summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-12 05:54:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-12 05:54:17 +0200
commitb88f4ebf568946eb70d230e088f368016c960005 (patch)
tree33a11299ac32008473d74be63b6b8765e9216461 /dev-python
parentdev-python/botocore: Bump to 1.35.17 (diff)
downloadgentoo-b88f4ebf568946eb70d230e088f368016c960005.tar.gz
gentoo-b88f4ebf568946eb70d230e088f368016c960005.tar.bz2
gentoo-b88f4ebf568946eb70d230e088f368016c960005.zip
dev-python/boto3: Bump to 1.35.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.17.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6bf29e54889f..fb2b74ff9608 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,4 +2,5 @@ DIST boto3-1.35.10.gh.tar.gz 856679 BLAKE2B 03e7be74455b487a79188405796fc08bd940
DIST boto3-1.35.14.gh.tar.gz 859166 BLAKE2B eb201a319453097068b4711356ea930de739ff8874da7441fa3b931434c8a82a1692a5f67b10f06eaf7644335033e302f733fcc2267b782398e9edd28c32a613 SHA512 ade4b6bc0c816244d5335b1669090d8a5e3c8dcc8802b0aa10498ce8c5fe8e456958ff3bfd73a5c9376ce1658f9c2a90d5470c86c2b3399d7198bacd09764619
DIST boto3-1.35.15.gh.tar.gz 859778 BLAKE2B f704c28f5510c0f495bbfd2e09ea303efedbcd96fc0d4a76ce2790c0e9e4814a678f30812d6b2c70225e0dd78ad7a38a2148aa7245d65a642409c9e693f39030 SHA512 d34ad96c6cc0e8ff29dc2b74872bf20cc69618cba72f3429425f5ad922bc669427ea709aa03642ced59b7acfd446e243067aa773930be1ff3dfe9fa8b7b9c2a4
DIST boto3-1.35.16.gh.tar.gz 860020 BLAKE2B 2368b713cd51fd61596f50849e68f82188156a9ba80cf2b7608536f67ff9e57cb7e5cbd5529ab573d0fe1441d9572d3e8d2e6d0cd41e82237d968284c14247aa SHA512 5f5cf28b8dda8f1a136101095232346eafad886cea4ea5184295e7dd5233a18c04d51bd0398fc340d4092a916bdecfec0b7b71e009ec5e33dec86c445fcd05ac
+DIST boto3-1.35.17.gh.tar.gz 860345 BLAKE2B 7c12c48a9f72eb278ec3ab4416770a9314b6c2177329c5ed6213e19464efe8c7979f4ef7ab821085a06f6ca8b46317a08a571ba9bcf98c157ab81022a6f889e0 SHA512 bb83a4b4f5738001ca51817f7557d7e71bd214028ab509e16f9e6743d7f108b524cf994ff659ab5a9bae0285924d36eaed18ce5381da1d7aefb1dfec03588b97
DIST boto3-1.35.5.gh.tar.gz 854016 BLAKE2B f94d738e310725cd5f9c7b405a094155f3ecf640f02045662ed94ab3689ea549fde7eee19ae2be450768560ad705b8740fda78b79ed42cf536231626d247e09a SHA512 fc1106abbb306bacb80dce825bf71303e71b0d0698d7e3bb4dcaca4ea6e4f7a97e70753367200294f334b351e764bca57f2316afec854d2e46db4644dfefc25b
diff --git a/dev-python/boto3/boto3-1.35.17.ebuild b/dev-python/boto3/boto3-1.35.17.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.17.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}