summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 04:32:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:37:19 +0200
commitb58561cfc2c05af7c15f65aa9041d011730c817c (patch)
tree12677ddeaa7af9c6f27fd3b4b1ff6bc5a19e4a51 /dev-python
parentdev-python/blinker: Bump to 1.8.0 (diff)
downloadgentoo-b58561cfc2c05af7c15f65aa9041d011730c817c.tar.gz
gentoo-b58561cfc2c05af7c15f65aa9041d011730c817c.tar.bz2
gentoo-b58561cfc2c05af7c15f65aa9041d011730c817c.zip
dev-python/tcolorpy: Bump to 0.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tcolorpy/Manifest1
-rw-r--r--dev-python/tcolorpy/tcolorpy-0.1.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tcolorpy/Manifest b/dev-python/tcolorpy/Manifest
index 5d84ad3c2507..f85b85d17337 100644
--- a/dev-python/tcolorpy/Manifest
+++ b/dev-python/tcolorpy/Manifest
@@ -1 +1,2 @@
DIST tcolorpy-0.1.4.tar.gz 11072 BLAKE2B 2ceefe31475d44546efbf919c6353caf3d023f269f1cf373185900704c88d318bd7c96beae2e0ef287a695ef1cf7367fd5e5dd21d73a61400b17a9a40d1d727a SHA512 4be98b0819c6eca0af55170e473e26b90d0c62b81c00fb1fe66b197f1fd6e7aec38cdd2b24dcc1b059af0ed1a54cfdc0900fad2e9145bf49b578d90edc65e74c
+DIST tcolorpy-0.1.6.tar.gz 298986 BLAKE2B ed21c484df83ce6e4d8a90acf982bd574dc308939599e451767006412f762ab71781ce41c98ccf1aafc39a19c12a862bb801ffb0a459b09310a01c9c5a35101d SHA512 c96cfbba2c42a17618aa68f252f6e18a5a842eeeced0d2ccdf6aee903d5552375575652bb4d6417e4e0f566b92750afccf9c3fc1866b67b95ab91d4129c02a0a
diff --git a/dev-python/tcolorpy/tcolorpy-0.1.6.ebuild b/dev-python/tcolorpy/tcolorpy-0.1.6.ebuild
new file mode 100644
index 000000000000..0d644aa6e233
--- /dev/null
+++ b/dev-python/tcolorpy/tcolorpy-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="tcolorpy is a Python library to apply true color for terminal text"
+HOMEPAGE="
+ https://github.com/thombashi/tcolorpy/
+ https://pypi.org/project/colorpy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest