summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-15 05:02:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-15 05:49:32 +0100
commitb3ffa51b3acd45ef3692c84822dce0dd5d54b68d (patch)
tree4d1905fd48e6459d445694c16ddba57f52e99b90 /dev-python
parentsys-cluster/charm: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-b3ffa51b3acd45ef3692c84822dce0dd5d54b68d.tar.gz
gentoo-b3ffa51b3acd45ef3692c84822dce0dd5d54b68d.tar.bz2
gentoo-b3ffa51b3acd45ef3692c84822dce0dd5d54b68d.zip
dev-python/botocore: Bump to 1.34.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.63.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ce4ef57cdd7f..92e62cbbaf25 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.59.gh.tar.gz 12764223 BLAKE2B 13347793764afb8ef51502149f490e5
DIST botocore-1.34.60.gh.tar.gz 12765697 BLAKE2B c9aadf76475fe4cdd81d3aff1fd577bc177cb6f4702e8f4acbce8a5d2010a6440e792ae2accf7af3cfafca146b22ce9b239d76a25c8f9715b34d44212e9e2c73 SHA512 4d44646840dfaab1d5d45705be74df73df1b76dc345ee189c4d8b82cbffc5076701a34771823b18c4c52c4a8a9acc8c7e186ad25b7a735de95944d9f439ef8b4
DIST botocore-1.34.61.gh.tar.gz 12767176 BLAKE2B dd8fdd5fd15b4da9b1b8550dff8d2d51ceba0a1720665d0a9abdfd9519450eb6eb428f5febc58494f06e8406605ce0c8fb1e61ea1c3a25630c2b36944decad7a SHA512 da3299d3231c5b16a12b6ebb1456baea5ed94e8f05de75457b3ce2c9cdf2071c045c32326fdd84d29ac1d15e6379c40611db3ba07037498f6c43e79ef0880fac
DIST botocore-1.34.62.gh.tar.gz 12768327 BLAKE2B 06e5fcf4fde0e17257864883c76d04e0b09ad932c6418b342d01a0631aa134a982b541b58ce2a5eb52802b0ea9432a0ea3f7761af346b172f84d48657b45e53e SHA512 daffa72c08c227f584b08d9d3400e7d6194d1adf6895e79dec9d33a6e4457469e4d89bb65e808e6783858cbdd0888ebfcf3352ebf6c757180a1a262389facb42
+DIST botocore-1.34.63.gh.tar.gz 12772160 BLAKE2B fe94240d00fa22ffc9b2e6ffc67ad30cf0f095e902ed41924357201cce8205801ea4e717b42dad09ad5703f35ecaba927b43e1ca6e1b6059d7c8ab868adf5734 SHA512 25186264a67ec52e800c8eeec5e0d4ebc14afca5ee4c05ae54fcf1aa7aaaf73be086c261f5781b5636b7ea2a99615b7ab106b991f125be2742e865ba79dffff8
diff --git a/dev-python/botocore/botocore-1.34.63.ebuild b/dev-python/botocore/botocore-1.34.63.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.63.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}