summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-02 23:52:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-03 10:11:26 +0100
commit2f5ead4e49238cbad0dd2a3442608d47c3458001 (patch)
tree0061c76d77c1e68b7d32ba57fc17cf06abc947ac /dev-python
parentdev-python/django-compressor: Clean old up (diff)
downloadgentoo-2f5ead4e49238cbad0dd2a3442608d47c3458001.tar.gz
gentoo-2f5ead4e49238cbad0dd2a3442608d47c3458001.tar.bz2
gentoo-2f5ead4e49238cbad0dd2a3442608d47c3458001.zip
dev-python/django-debug-toolbar: Clean old up
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-1.3.2.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 880b43fab371..01ba026b5921 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1 @@
-DIST django-debug-toolbar-1.3.2.tar.gz 316106 BLAKE2B 41ca813e252d54096ae6077e247f36292d986a1ecc5d8e34bf856edd9f272e74d8078b6402aaa44805837b9dcbd762702b08502726f104f5363226b14ca668db SHA512 d1428f1f729a190ddbf3a260bc428d7a78421519be60c7f07ad3e7f3498414d4ac0ec64d5772fcf89d6521f83bd9226fae104c43b4f0ad4deaf7cfb427d24b1c
DIST django-debug-toolbar-1.5.tar.gz 315928 BLAKE2B 8dde3c655baa6bd5f3b5d3ae0ba57b8c5746fc41bcfae9f506ad5c49ff64cdb51f0b9d67ee42695f884493cf21bd76fdcf943d88d97641b5d804d54c59163562 SHA512 9a421b80016bdaee8dd3ba2a9b7c3b788b54a4f464cdd5697e36536268e4d3d926bf77088a715e87f192dc8a20a100d8adac68c9c26a1191a5343e377240bf64
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-1.3.2.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-1.3.2.ebuild
deleted file mode 100644
index 558b7505df84..000000000000
--- a/dev-python/django-debug-toolbar/django-debug-toolbar-1.3.2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_4 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A configurable set of panels that display debug information"
-HOMEPAGE="
- https://pypi.python.org/pypi/django-debug-toolbar/
- https://github.com/django-debug-toolbar/django-debug-toolbar/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="amd64 x86"
-IUSE="doc examples"
-
-RDEPEND="
- >=dev-python/django-1.4.2[${PYTHON_USEDEP}]
- >=dev-python/python-sqlparse-0.1.10[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- # Prevent non essential d'loading by intersphinx
- sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
-
- # This prevents distutils from installing 'tests' package, rm magic no more needed
- sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- emake test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( example/. )
- distutils-r1_python_install_all
-}