summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-23 18:12:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-23 18:35:09 +0100
commitf8610a0dc713b6ac5595bb1313ccdad054362831 (patch)
treeb4aeeed088aa9a38d9a3a2c6e645146babeeb22e /dev-python/zeroconf
parentkernel-{build,install}.eclass: add USE=generic-uki (diff)
downloadgentoo-f8610a0dc713b6ac5595bb1313ccdad054362831.tar.gz
gentoo-f8610a0dc713b6ac5595bb1313ccdad054362831.tar.bz2
gentoo-f8610a0dc713b6ac5595bb1313ccdad054362831.zip
dev-python/zeroconf: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest2
-rw-r--r--dev-python/zeroconf/zeroconf-0.127.0.ebuild56
-rw-r--r--dev-python/zeroconf/zeroconf-0.128.0.ebuild56
3 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index f1f0a2f8d0b9..f87d4dcd4697 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,5 +1,3 @@
-DIST zeroconf-0.127.0.tar.gz 161143 BLAKE2B ee560845016ab1de0b065aaae8cd6791ddc847417241c7f2477301948945e938a2ff68206d30166a6049a7ad5919d15bcc6acac9fd9d33d17d5e77154b9f9c0c SHA512 7c8aef766dcc0f3411c4230decd5a0af18ae795e0e4253be2dc69af6ba314271a336807ace1458bb0a081455afa8cc9d8769413bbc97f024e3d3e877cd1e6f2f
-DIST zeroconf-0.128.0.tar.gz 161199 BLAKE2B 7526c6f4a242e7ab0035ea3f2b29b3b43bbb6235950e7b2899472986e4186584275a39e6341c661203499528f47b2d255d4df3e2e092b0c864a1cf6b5c09a379 SHA512 d058828691a97c7634319fedcf688401d01ae372521d48b3749570975a5afbde839d14a4e34463c20fd267d006bf708c098a4f180844398a64fd96d1538edfa4
DIST zeroconf-0.128.4.tar.gz 162384 BLAKE2B cd8b60d0f0bdf01835fc1bf3c9bc74311ea4cc353ba1e0825264e850d070c8cee3565ec9942d825c404406623c7e65851688b447afbe1bf9884da077993a77de SHA512 d0781c1c5752eda31806826475cee0e7032e4bae9612adf0f8b7dab21d15be2762fb37af17a34f93f2f5f27ee936fcf4d7e58ce1d9b42af3e8681d5e8eb326ee
DIST zeroconf-0.129.0.tar.gz 163756 BLAKE2B 13ac698352fd18d2025ed60d6906e7add6726a07c0e5e29f4fbf5bdd9f666a17d0401acbab70197182e7112e98e03eceb8a5d64f927a15f52b592b669615a4ad SHA512 51e6edf5474e8bfcd63c31b13abc5ef382c4eab1e4d41e2d4f454615e1cc09aab63dc13f29c1a1126d3ae131c6d8df762748f0c5bdf2149c968517a0a15fc0ff
DIST zeroconf-0.130.0.tar.gz 169034 BLAKE2B cda4002e07fcb784ab03208d25bbe4dbb3349df9473a78fca3032b5ed5bc882edcd35179f4721e3ae4f12880f464d9ef43ad03216aa272b58f034f929aabd06d SHA512 8f2ce4ae9f58a28c658253a2c17a85968d51e2483442d726849ad254e5250f1b4e83f106540e7562369d4bbdfa05fc470636cc4a4f913dc5b1c94ea03b726d74
diff --git a/dev-python/zeroconf/zeroconf-0.127.0.ebuild b/dev-python/zeroconf/zeroconf-0.127.0.ebuild
deleted file mode 100644
index 4305169d6e62..000000000000
--- a/dev-python/zeroconf/zeroconf-0.127.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
-HOMEPAGE="
- https://github.com/python-zeroconf/python-zeroconf/
- https://pypi.org/project/zeroconf/
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# the build system uses custom build script that uses distutils to build
-# C extensions, sigh
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export REQUIRE_CYTHON=1
-
-python_test() {
- local -x SKIP_IPV6=1
- local EPYTEST_DESELECT=(
- # network
- tests/test_core.py::Framework::test_close_multiple_times
- tests/test_core.py::Framework::test_launch_and_close
- tests/test_core.py::Framework::test_launch_and_close_context_manager
-
- # fragile to timeouts (?)
- tests/services/test_browser.py::test_service_browser_expire_callbacks
- tests/utils/test_asyncio.py::test_run_coro_with_timeout
- )
-
- epytest -o addopts=
-}
diff --git a/dev-python/zeroconf/zeroconf-0.128.0.ebuild b/dev-python/zeroconf/zeroconf-0.128.0.ebuild
deleted file mode 100644
index b3ff07347a6d..000000000000
--- a/dev-python/zeroconf/zeroconf-0.128.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
-HOMEPAGE="
- https://github.com/python-zeroconf/python-zeroconf/
- https://pypi.org/project/zeroconf/
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# the build system uses custom build script that uses distutils to build
-# C extensions, sigh
-BDEPEND="
- >=dev-python/cython-3[${PYTHON_USEDEP}]
- >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export REQUIRE_CYTHON=1
-
-python_test() {
- local -x SKIP_IPV6=1
- local EPYTEST_DESELECT=(
- # network
- tests/test_core.py::Framework::test_close_multiple_times
- tests/test_core.py::Framework::test_launch_and_close
- tests/test_core.py::Framework::test_launch_and_close_context_manager
-
- # fragile to timeouts (?)
- tests/services/test_browser.py::test_service_browser_expire_callbacks
- tests/utils/test_asyncio.py::test_run_coro_with_timeout
- )
-
- epytest -o addopts=
-}