summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 09:20:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:23:56 +0200
commitb650d49600a4023750e3458ede017a307507f8e2 (patch)
tree712d2231f9e3492be58d7fa35eb6455ea821349f /dev-python/xlwt
parentdev-python/xlrd: Enable py3.11 (diff)
downloadgentoo-b650d49600a4023750e3458ede017a307507f8e2.tar.gz
gentoo-b650d49600a4023750e3458ede017a307507f8e2.tar.bz2
gentoo-b650d49600a4023750e3458ede017a307507f8e2.zip
dev-python/xlwt: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlwt')
-rw-r--r--dev-python/xlwt/xlwt-1.3.0-r2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/xlwt/xlwt-1.3.0-r2.ebuild b/dev-python/xlwt/xlwt-1.3.0-r2.ebuild
index b44e9116c0b8..22ebd92f8225 100644
--- a/dev-python/xlwt/xlwt-1.3.0-r2.ebuild
+++ b/dev-python/xlwt/xlwt-1.3.0-r2.ebuild
@@ -4,12 +4,16 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
-HOMEPAGE="https://pypi.org/project/xlwt/"
+HOMEPAGE="
+ https://www.python-excel.org/
+ https://github.com/python-excel/xlwt/
+ https://pypi.org/project/xlwt/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
@@ -19,7 +23,7 @@ IUSE="examples"
distutils_enable_sphinx docs \
dev-python/pkginfo
-distutils_enable_tests nose
+distutils_enable_tests pytest
python_install_all() {
if use examples; then