summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-03 07:17:54 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-03 08:10:31 +0200
commitd43f6ccd18a6d5c8a7e49fd77b0619ec6e29f3af (patch)
treecb573a5b5f64bb9a756b0bb34858e91ccfc18c9c /dev-python/xdoctest
parentx11-wm/evilwm: version 1.3.1. (diff)
downloadgentoo-d43f6ccd18a6d5c8a7e49fd77b0619ec6e29f3af.tar.gz
gentoo-d43f6ccd18a6d5c8a7e49fd77b0619ec6e29f3af.tar.bz2
gentoo-d43f6ccd18a6d5c8a7e49fd77b0619ec6e29f3af.zip
dev-python/xdoctest: Bump to 0.15.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch28
-rw-r--r--dev-python/xdoctest/xdoctest-0.15.8.ebuild33
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index d791719d1906..c9f8f197da5c 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,2 +1,3 @@
DIST xdoctest-0.15.4.gh.tar.gz 179295 BLAKE2B 0b44276a219119196543671d8ac24469ecd73b040bbd03ca416320d407f0dd34361dbb2778121621f6efb65835ea421107883277b6e712f03e4c06ea2b03dd6a SHA512 a0a35d5c73a8696266d9be44d11e9dbf05c9ac1165a05e681f7b70ef07ae7d56f4bd179e863b6675e2366f1627015e92092e8250ca592f004680db5ad886ad49
DIST xdoctest-0.15.6.gh.tar.gz 182717 BLAKE2B 39af1bdc381e6b6044321ca1dae8ae893d4af9ba8d595ce5dad0fea7e805420635bc9f9a2c04726cb03a7fa0311eb1df1f93aa59e682790e15a3e119356d7b9a SHA512 5c7a7cfea9a7b37e8e5a383b59896730420dbf737a4217bd19ebe083b48a6d410b0e6713b0e5b9749527ff3992f3d24b83d49622bcde0a68722ecab8337d7040
+DIST xdoctest-0.15.8.gh.tar.gz 185463 BLAKE2B a16578e6d50398ac80d950bcc9a05131880816e2ff3a15bd1489474e532f9b495d099dcea204d8375c884c6957aaaba9b276fbcb65b5717b2850314453f787f7 SHA512 ab4f991ba6e312bf6cf675c3bbeeae87c0666b96c911ee7727f64b8e4c13420bb91e0a7a955ebce73b3fb15625b52bbf1b67c6edfe91234655501060b17723d5
diff --git a/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch b/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch
new file mode 100644
index 000000000000..193b3f51bbac
--- /dev/null
+++ b/dev-python/xdoctest/files/xdoctest-0.15.8-pytest-flaky.patch
@@ -0,0 +1,28 @@
+From ec14218904fdd1c06597277deb11c8d3bb33c675 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Fri, 3 Sep 2021 07:27:22 +0200
+Subject: [PATCH] Fix test failure if pytest's flaky plugin is installed
+
+Disable pytest's flaky plugin in test_simple_pytest_import_error_cli
+in order to fix a test failure due to it mangling pytest's return code
+on import error.
+---
+ testing/test_pytest_cli.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testing/test_pytest_cli.py b/testing/test_pytest_cli.py
+index 25c8363..8ef9251 100644
+--- a/testing/test_pytest_cli.py
++++ b/testing/test_pytest_cli.py
+@@ -67,7 +67,7 @@ def test_simple_pytest_import_error_cli():
+ """
+ ''')
+ temp_module = util_misc.TempModule(module_text, modname='imperr_test_mod')
+- command = sys.executable + ' -m pytest -v -s --xdoctest-verbose=3 --xdoctest ' + temp_module.dpath
++ command = sys.executable + ' -m pytest -p no:flaky -v -s --xdoctest-verbose=3 --xdoctest ' + temp_module.dpath
+ print(command)
+ info = cmd(command)
+ print(info['out'])
+--
+2.33.0
+
diff --git a/dev-python/xdoctest/xdoctest-0.15.8.ebuild b/dev-python/xdoctest/xdoctest-0.15.8.ebuild
new file mode 100644
index 000000000000..2fca586c7c28
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.15.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-flaky.patch
+)