summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:48:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 06:48:23 +0200
commit7c992caa9f40d3f513d8168244b6cd5765cf35df (patch)
tree4c2c7f99dcb7ed13dc59702ba6331a81b9381403 /dev-python/xdoctest
parentapp-admin/awscli: Bump to 1.33.4 (diff)
downloadgentoo-7c992caa9f40d3f513d8168244b6cd5765cf35df.tar.gz
gentoo-7c992caa9f40d3f513d8168244b6cd5765cf35df.tar.bz2
gentoo-7c992caa9f40d3f513d8168244b6cd5765cf35df.zip
dev-python/xdoctest: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 8dbb89d7d030..c0379d377f6f 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,2 +1,3 @@
DIST xdoctest-1.1.3.gh.tar.gz 227008 BLAKE2B dcda05cbbc692fe7dd7d6b49d92f980f997e3f5f7025406d2a26019f67486b2dc8f1657d9f8760e3034e6bed9f35d9dd7ab728a07a3e25596dab95327ecc8ba4 SHA512 5ee08f15bc01efee8be55c85aa259615bd433d9be02655ac48d7db93a72c5bf69f73562d7887e56836a74721b90517e797e5a128311438b22ace6f463ecf330d
DIST xdoctest-1.1.4.gh.tar.gz 230110 BLAKE2B a096dea40a783b7a0366ba00ab29e8cbd5e2be61c04ed790839b56674851ff2a8ad27a99a2a2523bac6e4b28c752ca683d2634ef5fa7bfb17708d8a637b867ac SHA512 cd2df8a01be14b5b2dc195621028c09a139b6cf952a853dea6548b706314f109fa88e27be331135d46aff8ca980a1e48a16c4afdedd368718a83c91ffa02bd34
+DIST xdoctest-1.1.5.gh.tar.gz 230382 BLAKE2B 0bbcd09464cc48d6450c746fc341892401bfa91a18be45ab340d291a4001a71f6d5a0fca6b3a7e869c2c34ce008e992fdac62fdd898a941659017e9bf68b7ae9 SHA512 6664eef216f7e83236673542bcdd75276c14260dd94026575e4e72ff41c6b4249909659e54a46fda84c49e22954fb169d23a1baf439823d28337731232803781
diff --git a/dev-python/xdoctest/xdoctest-1.1.5.ebuild b/dev-python/xdoctest/xdoctest-1.1.5.ebuild
new file mode 100644
index 000000000000..70d8909b5a6b
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}