summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 06:41:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 06:50:38 +0200
commit4ac9834e9d1bc73e09a2f1a50b5a8e8066c1dc2e (patch)
tree6f68aa02f26e1262910efadafe7441a6c43d7586 /dev-python/xdoctest
parentdev-python/xdoctest: Remove old (diff)
downloadgentoo-4ac9834e9d1bc73e09a2f1a50b5a8e8066c1dc2e.tar.gz
gentoo-4ac9834e9d1bc73e09a2f1a50b5a8e8066c1dc2e.tar.bz2
gentoo-4ac9834e9d1bc73e09a2f1a50b5a8e8066c1dc2e.zip
dev-python/xdoctest: Bump to 1.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.1.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 043223f831c7..79b83abd3c89 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1 +1,2 @@
DIST xdoctest-1.1.5.gh.tar.gz 230382 BLAKE2B 0bbcd09464cc48d6450c746fc341892401bfa91a18be45ab340d291a4001a71f6d5a0fca6b3a7e869c2c34ce008e992fdac62fdd898a941659017e9bf68b7ae9 SHA512 6664eef216f7e83236673542bcdd75276c14260dd94026575e4e72ff41c6b4249909659e54a46fda84c49e22954fb169d23a1baf439823d28337731232803781
+DIST xdoctest-1.1.6.gh.tar.gz 230764 BLAKE2B 9a46f5339e5e7c1904f71f80eecfa385d78775aea896cf86b26288f3fdc63045e17b3d420c48a0f53c57c8992d048d2b7610f09276d772c26e147f492a71d3ad SHA512 9d33e315cde68f1731cff8b4311c941a30aba0718a94f81ca198a2efe760c829f6d4984f0d1c273c554aef938d445d2556d78d7f06fbe4160efe5d94acea9a53
diff --git a/dev-python/xdoctest/xdoctest-1.1.6.ebuild b/dev-python/xdoctest/xdoctest-1.1.6.ebuild
new file mode 100644
index 000000000000..70d8909b5a6b
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="
+ https://github.com/Erotemic/xdoctest/
+ https://pypi.org/project/xdoctest/
+"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdoctest.plugin
+
+ epytest --pyargs tests xdoctest
+}