summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-20 16:25:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-20 16:25:09 +0300
commit19508795e4bcdcd1cac34546366ce8c26de21cc3 (patch)
tree40a9283fff0d4be0ab05921a50b992a527c641f0 /dev-python/xdoctest
parentwww-client/opera-developer: update ffmpeg version (diff)
downloadgentoo-19508795e4bcdcd1cac34546366ce8c26de21cc3.tar.gz
gentoo-19508795e4bcdcd1cac34546366ce8c26de21cc3.tar.bz2
gentoo-19508795e4bcdcd1cac34546366ce8c26de21cc3.zip
dev-python/xdoctest: add 1.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/xdoctest')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/xdoctest-1.0.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
index 15fcae8bf6f0..0e5ac09acc6f 100644
--- a/dev-python/xdoctest/Manifest
+++ b/dev-python/xdoctest/Manifest
@@ -1,2 +1,3 @@
DIST xdoctest-1.0.0.gh.tar.gz 193294 BLAKE2B 95725757faafd2a15652557e07753ad8c4a8ee57b545169ba29b6e8f0ef5c7a021eff3c092cfe123da91311db98ef7700b29d52b1418a8160869402fb4ecfcab SHA512 8c77fbd8fcd1a3030b33651d35567dd4506ece3aa2c6155223d5cdea6e16510b59bcbd5b9ebb6dc13e20af92c5d07dc205485566b836874e835b18a53cbe7355
DIST xdoctest-1.0.1.gh.tar.gz 200921 BLAKE2B 29d4947e8a49b11721c2ab8500e12334c9937d892519154267ad1ff3f98e3a35767eb770ed40d34c253e282e09e90de2567b92fd7b3167f7d8a58dcd762bc43d SHA512 c853f0b673ebc8b1f6fc6305a8688bffdf33cabab734a53f4ed1668d4f94d0431dd6e867b30a1c4588a86f3552e9b94ceaf540c3ed8e66f80bd9ce45ddbae690
+DIST xdoctest-1.0.2.gh.tar.gz 204010 BLAKE2B a11d3bee9f4bb32f3eea34630a359695290f72792cae57c8bdf789164068b40fddf637fb5676bc0a63dcd319394791872060499de031e063d0122e1888b2ccc9 SHA512 dede66113cf474e160da3b389d377fcb7e56d2db29c957d6ff279e4d52098395a1085d546bd9d7a739b72da7986d90ad55d264df54579c5257e47bf23551c714
diff --git a/dev-python/xdoctest/xdoctest-1.0.2.ebuild b/dev-python/xdoctest/xdoctest-1.0.2.ebuild
new file mode 100644
index 000000000000..a1433e00c391
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/xdoctest/"
+SRC_URI="
+ https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+# dev-python/nbformat-5.1.{0..2} did not install package data
+BDEPEND="
+ test? (
+ >=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs/source \
+# dev-python/autoapi \
+# dev-python/sphinx_rtd_theme
+
+python_test() {
+ epytest --pyargs tests xdoctest
+}