summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-10 17:50:59 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-10 19:11:46 +0200
commitd49f8bbcf7eddfd325d719694e22fd005ada1a04 (patch)
treea8c4d484a83262afcc907a7b04b8cde1ce8d02fe /dev-python/wtforms
parentdev-python/rebulk: drop 3.0.1 (diff)
downloadgentoo-d49f8bbcf7eddfd325d719694e22fd005ada1a04.tar.gz
gentoo-d49f8bbcf7eddfd325d719694e22fd005ada1a04.tar.bz2
gentoo-d49f8bbcf7eddfd325d719694e22fd005ada1a04.zip
dev-python/wtforms: drop 2.3.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/wtforms')
-rw-r--r--dev-python/wtforms/Manifest1
-rw-r--r--dev-python/wtforms/wtforms-2.3.3.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/wtforms/Manifest b/dev-python/wtforms/Manifest
index e757eba81cd5..6e3f707f4717 100644
--- a/dev-python/wtforms/Manifest
+++ b/dev-python/wtforms/Manifest
@@ -1,2 +1 @@
-DIST WTForms-2.3.3.tar.gz 162945 BLAKE2B 5f9f2c920ffc784c34d69f42cd259c1cb6007edbc99028bede98b7c3e24b8ba616b89eceac241cc9b20b241e758ee0c88a9c6736597ddc83c90542135a004fec SHA512 934cf1483beec37d698d13a81e44a733d082baad1f418d3087306fd908df809d37fffe000ed1ecabf65d2c31b57034bf6f25c3b77cfc5598ae1f65bf4a115fe5
DIST WTForms-3.0.0.tar.gz 137053 BLAKE2B 518dfadf248a70fd0627a822c646e884709e295517bc187750e42296896db16dddbe95aa67bf29624147e77fc9db7deb46f3ebc3558801f7b8a5895116df1922 SHA512 dbed8706a317022be07f9568d11c7dab6021642957efab38e547b7b1b83b1ac8863a521b8fb0f5f4ec15cdc2966520a76d079a00ea88ce56f40a42b335fcfc6e
diff --git a/dev-python/wtforms/wtforms-2.3.3.ebuild b/dev-python/wtforms/wtforms-2.3.3.ebuild
deleted file mode 100644
index feb41b797919..000000000000
--- a/dev-python/wtforms/wtforms-2.3.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_PN="WTForms"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Flexible forms validation and rendering library for python web development"
-HOMEPAGE="https://wtforms.readthedocs.io/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]"
-
-BDEPEND="
- test? (
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/python-email-validator[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # use pytest instead of ugly custom test runner
- cat >> setup.cfg <<-EOF || die
- [tool:pytest]
- python_files = *.py
- EOF
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local ignore=(
- # requires gaetest_common... also upstream doesn't run it at all
- tests/ext_appengine
- # requires old django; also extensions are deprecated anyway
- tests/ext_django
- )
- local deselect=(
- # incompatible with sqlalchemy-1.4
- tests/ext_sqlalchemy.py::QuerySelectFieldTest
- tests/ext_sqlalchemy.py::QuerySelectMultipleFieldTest
- )
-
- epytest tests ${ignore[@]/#/--ignore } ${deselect[@]/#/--deselect }
-}