summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 16:18:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 16:31:57 +0200
commit2b86877e49aff21cda2cf4790294e6b45e3ab01c (patch)
tree7f7de2321434800dda9bab0f4bce26ac25a2a91c /dev-python/webcolors
parentdev-python/uri_template: Enable py3.11 (diff)
downloadgentoo-2b86877e49aff21cda2cf4790294e6b45e3ab01c.tar.gz
gentoo-2b86877e49aff21cda2cf4790294e6b45e3ab01c.tar.bz2
gentoo-2b86877e49aff21cda2cf4790294e6b45e3ab01c.zip
dev-python/webcolors: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webcolors')
-rw-r--r--dev-python/webcolors/webcolors-1.11.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/webcolors/webcolors-1.11.1-r1.ebuild b/dev-python/webcolors/webcolors-1.11.1-r1.ebuild
new file mode 100644
index 000000000000..d4495336802b
--- /dev/null
+++ b/dev-python/webcolors/webcolors-1.11.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Color names and value formats defined by the HTML and CSS specifications"
+HOMEPAGE="
+ https://github.com/ubernostrum/webcolors/
+ https://pypi.org/project/webcolors/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest