summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-05-16 14:07:00 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-05-16 14:07:00 +0200
commit37cc1f11ce22a96933b89ec8e7843b17bdb79e1d (patch)
tree7ce1ae953ed5471f18f6e2ad2d092cb2397b6c8d /dev-python/waitress/waitress-1.0.2.ebuild
parentdev-python/socketpool: Add python3_6 (diff)
downloadgentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.tar.gz
gentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.tar.bz2
gentoo-37cc1f11ce22a96933b89ec8e7843b17bdb79e1d.zip
dev-python/waitress: Version bump to 1.0.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/waitress/waitress-1.0.2.ebuild')
-rw-r--r--dev-python/waitress/waitress-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/waitress/waitress-1.0.2.ebuild b/dev-python/waitress/waitress-1.0.2.ebuild
new file mode 100644
index 000000000000..7d407a99d663
--- /dev/null
+++ b/dev-python/waitress/waitress-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="http://docs.pylonsproject.org/projects/waitress/en/latest/ https://pypi.python.org/pypi/waitress/ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}