summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-02 05:29:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-02 06:46:50 +0200
commit6f5bd141e2a3f950a0225d0abeeef22b470a5285 (patch)
tree0ad1ed60fc12e2f9b6125a00f2712935bde050f7 /dev-python/untangle
parentdev-python/fixtures: Bump to 4.0.1 (diff)
downloadgentoo-6f5bd141e2a3f950a0225d0abeeef22b470a5285.tar.gz
gentoo-6f5bd141e2a3f950a0225d0abeeef22b470a5285.tar.bz2
gentoo-6f5bd141e2a3f950a0225d0abeeef22b470a5285.zip
dev-python/untangle: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/untangle')
-rw-r--r--dev-python/untangle/Manifest1
-rw-r--r--dev-python/untangle/untangle-1.2.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/untangle/Manifest b/dev-python/untangle/Manifest
index 6dfdf4d8abdf..5c81cda5ecc1 100644
--- a/dev-python/untangle/Manifest
+++ b/dev-python/untangle/Manifest
@@ -1 +1,2 @@
DIST untangle-1.1.1.tar.gz 3089 BLAKE2B d8b8ffe1adb2acbcdcde8e6f67231315b9f318c9e8e1496dfa23b0ac6dd68651e75e2d2e67f6d7d521002ad6b0e9c4cc30c155685b9df60b6b223d137add0632 SHA512 252c3d0ed8d004660adad8f37a179a4d1b2b46e9d7127aee59b596eac3f65684a7a8b5b881bec97ddaf5470aa678df407b903209eaa069a40f53dc2dde9a94b2
+DIST untangle-1.2.0.gh.tar.gz 23772 BLAKE2B b93edbd704d2e2664628de2496cd4bf9057501585155bb21dcabe0e56506e697afa11999d2f607119eb3b2a274721a1e29de16ca914391a4e6720b92b964b12c SHA512 83e34702385e69ee172042644fc2d50196e2cbeb403b7a06385e3e3fa701bb132807742453994f724df4bf85fd0915d73ec618c57f4c47995039fa15bb578007
diff --git a/dev-python/untangle/untangle-1.2.0.ebuild b/dev-python/untangle/untangle-1.2.0.ebuild
new file mode 100644
index 000000000000..afbb098c7cf3
--- /dev/null
+++ b/dev-python/untangle/untangle-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert XML documents into Python objects"
+HOMEPAGE="
+ https://github.com/stchris/untangle/
+ https://pypi.org/project/untangle/
+"
+SRC_URI="
+ https://github.com/stchris/untangle/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest