summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 06:17:18 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 06:17:18 +0200
commit403ac968805a4f5e10ecfcdd3d0ee9b2dc05682a (patch)
tree80ade8ccf5e98b2aa91da92049e40de18cd87beb /dev-python/trove-classifiers
parentdev-python/python-dbusmock: Bump to 0.29.0 (diff)
downloadgentoo-403ac968805a4f5e10ecfcdd3d0ee9b2dc05682a.tar.gz
gentoo-403ac968805a4f5e10ecfcdd3d0ee9b2dc05682a.tar.bz2
gentoo-403ac968805a4f5e10ecfcdd3d0ee9b2dc05682a.zip
dev-python/trove-classifiers: Bump to 2023.4.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 049b8deb9f91..8fb603dd3675 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1,2 +1,3 @@
DIST trove-classifiers-2023.3.9.tar.gz 15792 BLAKE2B 1b96dae0f4a141ab5a5e4f3ebe5fbede972b6d09cd289bded3192dfffb26dd68d85bdd46bec20c1b9fb83dc3f8c521e4512a995fe5950c07c9ccf8d53986aca3 SHA512 a94b4c6d7102934677c4debd55274770d4de7db9ad641a253e4718f65dd4b624a4b0c8f6e83cdaf5ea484cecc975baf8dcee0e50824fc373760b8c5cc2e25f89
DIST trove-classifiers-2023.4.18.tar.gz 15808 BLAKE2B 72b6b7efa53d40859464f5b055bd62d9a5e82032bcf9be22ec2108761ab383d24791ea2707f96c5cc54af271bfa66f8d17cbe665271aa5c87333aa16e4b58b02 SHA512 b56c4c1c44f3c68b9499fe754adce169202b6bd406d00234ad11d8d6ba9ce0ddb13ea883cfe83e342bd580f3021bf304ea30ed9fe6ef214c8ce60fceab0ced99
+DIST trove-classifiers-2023.4.20.tar.gz 15814 BLAKE2B 5f28f08143f9a08f3a731133b8eac32276b6d5ea582b7e4f6700a481b87da6ffce4cbf0ca6e9a2a70713ad1bdecec27427e60c0751dd2f5ecaace21f68b74221 SHA512 cc046e1cc7d4ff10829b3f6ff9ccedd1f2143bc27c84232dabc79368d78648266166f96fbcc50c8690bef47d28d1920c9855fcf1483620b003b7366b3ba798bc
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
new file mode 100644
index 000000000000..e404744e2dba
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.4.20.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}