summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-31 08:16:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-31 08:54:58 +0200
commit0320032688c90ed89ecda6771ac82d6383fb81c8 (patch)
tree1f629fdda4995cd2428353e63511942e40a0d8d9 /dev-python/trimesh
parentdev-python/pygobject: Remove old (diff)
downloadgentoo-0320032688c90ed89ecda6771ac82d6383fb81c8.tar.gz
gentoo-0320032688c90ed89ecda6771ac82d6383fb81c8.tar.bz2
gentoo-0320032688c90ed89ecda6771ac82d6383fb81c8.zip
dev-python/trimesh: Bump to 4.4.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trimesh')
-rw-r--r--dev-python/trimesh/Manifest1
-rw-r--r--dev-python/trimesh/trimesh-4.4.8.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 9b5414a3770f..cddbcfb2bdf2 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -1,3 +1,4 @@
DIST trimesh-4.4.4.gh.tar.gz 13606701 BLAKE2B 52df2a318adbc1ef263734d1ecc55121c486a8d546a5e3452d38f6e580e89dabe72eb8f437e023391bf5ae10a145d453ef1b3309af8d7a8fd37d20aa14f92832 SHA512 afeeca5532208bacca9e5539d894f72c7e93975c9f932487a852033ed75d20fe29a66880c62d3daf1ff328c198e40464ad3751c69e190994fd0ccc19da5723cf
DIST trimesh-4.4.6.gh.tar.gz 13606676 BLAKE2B 8183a757067d531bac4a959d770e619b6b9ccfc629e39a8b7ee9cc372aec518a056c7d0c27016103b2e535174046a4387e9719d0e9b749a8c4ee32b610f82211 SHA512 33b4ae7b5c5336140be7eedff82f112e3830bbddf835042b1ea7b95e643fe7e8943c38e80518778be122c1ec76d151af870df9afbce011438b38c13f967d4e4a
DIST trimesh-4.4.7.gh.tar.gz 13606593 BLAKE2B 1847d601711df60257a8f1248cdea66fcc6489b570606c9ab1d360db2742a9e7c1f0d6093924afa7105a5a272e80c291b1c3568b041db2ee4d144e72ab44fbd8 SHA512 b3e1a670b8dec26df3357cad4205431e94fc2b59b87af976b0754ac8e46f4f930f768322f0aa236a6205c289b9037f2343ec6aaeb0e281f021a03d3147be3d20
+DIST trimesh-4.4.8.gh.tar.gz 13608241 BLAKE2B a9c429d1061f07ba84db4ab87275ad995550dcbd09b73baa7e7b0007bf17294fd812e7d530b7f76027c0c9b8d53cc8394a03e92218172bcd11791eba6e018fb7 SHA512 a2372a07561df5431159cb89bc344fbd9120aa2f6f0739a8fa0effd71fb001d3029c885581dc0b8c52be23f1cf87a22d53562a5ee25d534422ecb40fc0fd868e
diff --git a/dev-python/trimesh/trimesh-4.4.8.ebuild b/dev-python/trimesh/trimesh-4.4.8.ebuild
new file mode 100644
index 000000000000..37fd5b19ad93
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.4.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ dev-python/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox-earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require pyinstrument
+ tests/test_sweep.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox-earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}