summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-16 06:46:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-16 07:05:00 +0100
commit32ea19c5eeb32c48778203493aaa10cbec69a383 (patch)
tree3e5876d5f5baecb6b61f5ca8a30768e30a49a7ca /dev-python/theano
parentdev-python/theano: Remove Python 2 from 1.0.4 (diff)
downloadgentoo-32ea19c5eeb32c48778203493aaa10cbec69a383.tar.gz
gentoo-32ea19c5eeb32c48778203493aaa10cbec69a383.tar.bz2
gentoo-32ea19c5eeb32c48778203493aaa10cbec69a383.zip
dev-python/theano: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/theano')
-rw-r--r--dev-python/theano/Manifest1
-rw-r--r--dev-python/theano/theano-0.7.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/theano/Manifest b/dev-python/theano/Manifest
index 66c0e87d90b1..56b8e6682d5b 100644
--- a/dev-python/theano/Manifest
+++ b/dev-python/theano/Manifest
@@ -1,2 +1 @@
-DIST Theano-0.7.0.tar.gz 1985387 BLAKE2B 00d547d5d1f6bb4049a1db71442381ae3803be683975ccca7536b8971e066ac1d09a4fc93a7f70693ae052bbf681e0c59a8b30a326f862f870e10422b438f979 SHA512 6e6bf9afdebf3c281d71f5ceda73792e0a52b403b18776a639665767ac73ac4920b5042e29d656d517b8f023e5f9cd5a27086e0456dc40c42abf6f3569da3f06
DIST Theano-1.0.4.tar.gz 2840691 BLAKE2B 7f89caee3dd50d75ff09693fde7926f2b7da0f94758ef932f207feea29d74d38ed56591e6ebe0b46cfa043d5fb46d5b97028171acdfd324a01eb7b904169b4ac SHA512 3cc7f9dbb606c3c997c8651c34dd861721d5a8b99d06ed0887306d5a5ad0d7e402fbe29dcb5ad2f513b3bf75966e41a2854ebdf9a4fb212607345f84f367de8c
diff --git a/dev-python/theano/theano-0.7.0.ebuild b/dev-python/theano/theano-0.7.0.ebuild
deleted file mode 100644
index 9765e72f92ac..000000000000
--- a/dev-python/theano/theano-0.7.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator
-
-MYPN=Theano
-MYP=${MYPN}-$(replace_version_separator 3 '')
-
-DESCRIPTION="Define and optimize multi-dimensional arrays mathematical expressions"
-HOMEPAGE="https://github.com/Theano/Theano"
-SRC_URI="mirror://pypi/${MYPN:0:1}/${MYPN}/${MYP}.tar.gz"
-
-SLOT="0"
-LICENSE="BSD"
-IUSE="test"
-RESTRICT="!test? ( test )"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.6.2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-libs/scipy-0.11[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MYP}"
-
-python_prepare_all() {
- find -type f -name "*.py" -exec \
- sed \
- -e 's:theano.compat.six:six:g' \
- -i '{}' + || die
-
- rm ${PN}/compat/six.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}