summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-18 06:10:44 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-18 06:26:38 +0200
commitd6505a7f0122ee7c93fa664d0d7946916fc01a41 (patch)
tree7d41d25e9b95dca728453589068e52befeff8443 /dev-python/tenacity
parentdev-python/jaraco-text: Bump to 3.12.1 (diff)
downloadgentoo-d6505a7f0122ee7c93fa664d0d7946916fc01a41.tar.gz
gentoo-d6505a7f0122ee7c93fa664d0d7946916fc01a41.tar.bz2
gentoo-d6505a7f0122ee7c93fa664d0d7946916fc01a41.zip
dev-python/tenacity: Bump to 8.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.4.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index c2af38d2325e..b8dfdd640884 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-8.3.0.tar.gz 43608 BLAKE2B fcf7471110c831cfab20c81bb0bfa2c2895ce33b6cdf22c21dfd0f219eeb674dc4e7f4186e7c9a3366574636becd7391d68acb285069844ccaf358da6afa9c02 SHA512 46152ffacc0a87931cec09bd90eed3d2ad46f89101997c5da2aa510844c814b887a83805b4ec0de6a56759a7f2bcbab0cb2b2f1a4e6c11860ae53f64ff2a4c31
+DIST tenacity-8.4.1.tar.gz 45426 BLAKE2B e5cb1ed5a93a28a5733b7c25f95a5d9c4d4e341b5185c235e93bcf681590a72cd3895a1e9b24eaa31b939168f6420e8a28a5d8b982847886e9a799a983d41df8 SHA512 7abf17c5c4dbcb45aff3b660f70daa80fc673aa36e0ed95941a566d3740238d051736bc0da330110300bd4beae9a8a56082c4348d24e6bfa20a269bac771d956
diff --git a/dev-python/tenacity/tenacity-8.4.1.ebuild b/dev-python/tenacity/tenacity-8.4.1.ebuild
new file mode 100644
index 000000000000..6b916a7dff79
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest