summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 10:51:42 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 11:04:10 +0100
commitf4742bcf86be2a2a44a192f22730d3a8430e3649 (patch)
treec26822d3676019fb7a5edc437f3b55cc987b18ed /dev-python/tavern
parentdev-python/jupyter-server-terminals: Remove old (diff)
downloadgentoo-f4742bcf86be2a2a44a192f22730d3a8430e3649.tar.gz
gentoo-f4742bcf86be2a2a44a192f22730d3a8430e3649.tar.bz2
gentoo-f4742bcf86be2a2a44a192f22730d3a8430e3649.zip
dev-python/tavern: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tavern')
-rw-r--r--dev-python/tavern/Manifest1
-rw-r--r--dev-python/tavern/files/tavern-2.6.0-py312.patch38
-rw-r--r--dev-python/tavern/tavern-2.6.0.ebuild59
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/tavern/Manifest b/dev-python/tavern/Manifest
index 2ceb8d3aeb1b..55e2a543bd9f 100644
--- a/dev-python/tavern/Manifest
+++ b/dev-python/tavern/Manifest
@@ -1,2 +1 @@
-DIST tavern-2.6.0.gh.tar.gz 217509 BLAKE2B 99d9990757930a45a86a914fcf656b63266266869542cbd9b59850c7d648f54993ad5f409f12d09fbb12383c7586ecaeed323b04b478d62c7331cf514faa970a SHA512 1165dcc41244259d2ef7f69370dd35a40a9411b2a5c05e5dae45fc413d88478cd49aa540175a4a65dcf7dcd0eb2ee06b4f97059eb5d69ed5684893a8d5e8fcdc
DIST tavern-2.7.1.gh.tar.gz 220388 BLAKE2B 3e689ff0c29ddf2e53e018f86c79ea7e4e89e586d5f28b79c93263a10c4e7738fbf4c66df81fd55bc13a812223e538726f3f9b9f8bdbb94e7f043e90c70af2ce SHA512 de2822ec746c2ccb27a401c07bc5618539e4ad309e56437d0c66669612f48658fc352e42a0b4db94f9c183a159bbdcbeabdf30bebeac03c5f6a9f51bc7014b76
diff --git a/dev-python/tavern/files/tavern-2.6.0-py312.patch b/dev-python/tavern/files/tavern-2.6.0-py312.patch
deleted file mode 100644
index 679b0c9d2358..000000000000
--- a/dev-python/tavern/files/tavern-2.6.0-py312.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 8c09a6f31d84904dcf411e50102ac1ad159e4dd9 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 19 Nov 2023 08:56:20 +0100
-Subject: [PATCH] Fix assertion in TestCheckParseValues::test_warns_bad_type
-
-Fix the assertion in TestCheckParseValues::test_warns_bad_type
-to use `.assert_called_with()` rather than non-existing `.called_with()`
-method. The latter is wrongly interpreted as calling a mocked method
-in Python < 3.12, and therefore does not test anything at all. Starting
-with Python 3.12, it results in an error:
-
- AttributeError: 'called_with' is not a valid assertion. Use a spec for the mock if 'called_with' is meant to be an attribute.
-
-Fixing the call also revealed that the assertion was incorrect, so I've
-updated it to match the current call.
----
- tests/unit/test_helpers.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/tests/unit/test_helpers.py b/tests/unit/test_helpers.py
-index 0d3da1c4..19fddc08 100644
---- a/tests/unit/test_helpers.py
-+++ b/tests/unit/test_helpers.py
-@@ -300,10 +300,10 @@ def test_warns_bad_type(self, item):
- with patch("tavern._core.dict_util.logger.warning") as wmock:
- _check_and_format_values("{fd}", {"fd": item})
-
-- assert wmock.called_with(
-- "Formatting 'fd' will result in it being coerced to a string (it is a {})".format(
-- type(item)
-- )
-+ wmock.assert_called_with(
-+ "Formatting '%s' will result in it being coerced to a string (it is a %s)",
-+ "fd",
-+ type(item),
- )
-
- @pytest.mark.parametrize("item", [1, "a", 1.3, format_keys("{s}", {"s": 2})])
diff --git a/dev-python/tavern/tavern-2.6.0.ebuild b/dev-python/tavern/tavern-2.6.0.ebuild
deleted file mode 100644
index 68031898040d..000000000000
--- a/dev-python/tavern/tavern-2.6.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool, library, and Pytest plugin for testing RESTful APIs"
-HOMEPAGE="
- https://github.com/taverntesting/tavern/
- https://pypi.org/project/tavern/
-"
-SRC_URI="
- https://github.com/taverntesting/tavern/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/paho-mqtt[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-2.6.0[${PYTHON_USEDEP}]
- dev-python/pykwalify[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/python-box[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-6.0.1[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/stevedore[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/colorlog[${PYTHON_USEDEP}]
- dev-python/Faker[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${P}-py312.patch"
- )
-
- # strip unnecessary pins, upstream doesn't update them a lot
- sed -i -E -e 's:,?<=?[0-9.]+::' pyproject.toml || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p tavern
-}