summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-21 14:24:51 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-21 15:00:05 +0100
commit2a5f1d52d1136dec315f717d2f1491b2ea78a7d1 (patch)
treea4af29d5a8f87e0b5320eb734f1043997b0da75c /dev-python/subprocess-tee
parentdev-python/subprocess-tee: skip tests triggering issues with dev-python/enrich (diff)
downloadgentoo-2a5f1d52d1136dec315f717d2f1491b2ea78a7d1.tar.gz
gentoo-2a5f1d52d1136dec315f717d2f1491b2ea78a7d1.tar.bz2
gentoo-2a5f1d52d1136dec315f717d2f1491b2ea78a7d1.zip
dev-python/subprocess-tee: enable py3.11 + PEP-517 mode
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/subprocess-tee')
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
index 07ec6f767cea..3c4eaee3f160 100644
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
+++ b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
inherit distutils-r1
DESCRIPTION="subprocess.run replacement with tee(1)-like output"