summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-11 23:04:29 +0300
committerMichał Górny <mgorny@gentoo.org>2023-08-12 04:19:57 +0200
commite6b5ab2b53e92eb37dd80e57cc723f6975d23bba (patch)
tree4b8a4cb7e452a87db1c95fd057b4daa4de05fb60 /dev-python/sqlglot
parentdev-python/sphinxcontrib-trio: Remove old (diff)
downloadgentoo-e6b5ab2b53e92eb37dd80e57cc723f6975d23bba.tar.gz
gentoo-e6b5ab2b53e92eb37dd80e57cc723f6975d23bba.tar.bz2
gentoo-e6b5ab2b53e92eb37dd80e57cc723f6975d23bba.zip
dev-python/sqlglot: add 17.12.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32266 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.12.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 8fdc8b794a7c..0851171444fe 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,3 +1,4 @@
DIST sqlglot-17.10.1.tar.gz 8394322 BLAKE2B e7d922644e3071ccc6ce666b10081ce24095cbed6d2136c70e632d241196058762167874b175e6b000dda91922d72000fd6f57d8ae775dec588915f10a51d2e8 SHA512 6cbf3c82e5fee73dcbfe677213c10325a5fb81c8f93ba594d88abe9fb7d3a6580c6c6adebc6551cbe1dc8ae51ad68ac33a0242088e68dd80ef3e7285f4479ad1
DIST sqlglot-17.10.2.tar.gz 8399314 BLAKE2B c9695273925485f366f155f15a741074ed9b8f91ca5dfd7b233af8c43acb9dddfd48125218f12b47a4a1ad4003299e49ce532e4ff8a24a6cf6b074b6e069b484 SHA512 806b59eaca0b90f94fea9613313763276fd4def1b34e4781b7c5a05dfec446b3d6ddbfe27bf9c6f631820220013cae390f3e251ed432816d7598ed3140993d89
DIST sqlglot-17.11.0.tar.gz 8399720 BLAKE2B 28a2da06afc70a510ad046d25432c2b145fc10374ecc41b78052e22ba771dc21d57503d5335839cf3c227fc53c12365f4cc2d6a4c9e1e1ccf02b71266e7e0cdb SHA512 026af3b24a2c62efee937238eaa69ebc47dd0ee8e2979cacd28a45c565dc36f3aa1e03f0fe46265a1f9c5e379eacc54f730c57b06bf80962ccb87d43893fc9e3
+DIST sqlglot-17.12.0.tar.gz 8402758 BLAKE2B e563aecabdac819c55eabd678a12ee2a83f7a074eaa3d58d27503b04828233527c7320d237b699cc209f849d57d3b262a164f157fd4f24d1b125206994a45782 SHA512 d2e64e3692b93138f30904fab28490a3c9598e0201627112c29588c20889981354e2bf82ee844609d7633ea44aab9855159f294a6d711bb144ab922ed5ce1078
diff --git a/dev-python/sqlglot/sqlglot-17.12.0.ebuild b/dev-python/sqlglot/sqlglot-17.12.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}