summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-09-07 23:43:29 +0300
committerMichał Górny <mgorny@gentoo.org>2023-09-08 06:54:29 +0200
commitc356e2d82847e1b31067048384cf7c4234a85908 (patch)
tree220dccbff937cb0211858bd55f9cbd7eb0147ab8 /dev-python/sqlglot
parentdev-python/pyfuse3: Remove old (diff)
downloadgentoo-c356e2d82847e1b31067048384cf7c4234a85908.tar.gz
gentoo-c356e2d82847e1b31067048384cf7c4234a85908.tar.bz2
gentoo-c356e2d82847e1b31067048384cf7c4234a85908.zip
dev-python/sqlglot: add 18.3.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32678 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-18.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index da9691c69a8c..a7a88229ce1b 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -3,3 +3,4 @@ DIST sqlglot-18.0.0.tar.gz 8563952 BLAKE2B 6feb815c0169c6bbf12942a162ab769d1acba
DIST sqlglot-18.0.1.tar.gz 8567474 BLAKE2B 434a31e12f98ba88e4f6fe7c34dff7f69dc991257ed4f976a4f263cb40844c41ace79ec0bf4793aee73e8359ddf4d538bee6d8dea79f9e920788b3c3ee3ef8e5 SHA512 729cea4c03a5bf2b658ca2cede31454d46275bc03af946ba238f1d79c190d3a3bc62521dd6310c544469199027fb9eadc901e919a9ce5e34fa6f4eeb18ac48ad
DIST sqlglot-18.1.0.tar.gz 8570691 BLAKE2B 5c38baaa9600222c43f11338f2050eaf2e382752aa9df418e6cd8520e5a778e1d5cb6ae21a6cb2602a9ab313b993a43c9e72a26499ccc9cfe79995404bbb0975 SHA512 d9a543142514bb6422541085be900e466600bbf0d23f4f69eb817bcd1c5dcf9c3783b11f385a1379a68723eec4605e0372bf5dffa008426566d07a4d518009c3
DIST sqlglot-18.2.0.tar.gz 8585675 BLAKE2B e66be52c97f18811e30d9ee2a3a8ae99ddb72e860a05f85fe48bb3e4b94c089fa425cf21ea66f2c6e45ac6f3823f339eb9fcfd1598a1c7a80d519790a6c0fc8a SHA512 3dffe0a7a6325829d648d988b4fe43cc27121a4d6684c863aee926c2100061309491cb1b5c6ad4076222b97131636cb843d705d7f4097aa600e177577e8ec7c4
+DIST sqlglot-18.3.0.tar.gz 8599907 BLAKE2B 77e238dc8c8afe2c62a3c8c0ced6afbb0358a776189cef5e08b2c4830da04e573b11f703824a5038c5cf8d27cc31ac92f014aab459932742d8425ca834a6d473 SHA512 63ac8356483d13d6a53421f5fde8a4b2f56f34dc68d1d19a21e625c292a8ca9258da30905fd029dbe7bda59aebd0e358fa6e82cef240304ed1c571cfd19fc212
diff --git a/dev-python/sqlglot/sqlglot-18.3.0.ebuild b/dev-python/sqlglot/sqlglot-18.3.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}