summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 05:59:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 05:59:21 +0200
commit7324763dc0eb89723b2a5a7dd5facb09007dc494 (patch)
treec20b22604ffac40475f133d7ff3b0d7d05ce5c9b /dev-python/sqlglot
parentdev-python/hypothesis: Bump to 6.82.7 (diff)
downloadgentoo-7324763dc0eb89723b2a5a7dd5facb09007dc494.tar.gz
gentoo-7324763dc0eb89723b2a5a7dd5facb09007dc494.tar.bz2
gentoo-7324763dc0eb89723b2a5a7dd5facb09007dc494.zip
dev-python/sqlglot: Bump to 17.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.16.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index ed8f4a4a6d60..9444a3116875 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -7,3 +7,4 @@ DIST sqlglot-17.14.2.tar.gz 8498185 BLAKE2B c556387a77aa2d5a52ce2f0ac630253ea68b
DIST sqlglot-17.15.0.tar.gz 8505061 BLAKE2B 60ab18f09a5540d1442b03b6eae104f01642808ab0081df5e387eaa9a8c188b21cc1574e0c63d3d0eeddef023c2d3d0008a0e6f0e7e5ce8cdadde51b40e8641e SHA512 efca36e7fffcaff3379a870266e6978452a06a502d179d5bb1ba3dbf6f2d84bd9ef8f7967f82d6512ab6d420b755d3ea2c3bd243a4f7c5e8baccd4dcd183d390
DIST sqlglot-17.15.1.tar.gz 8536088 BLAKE2B 6b3e0663a4707bc5c94749765919f9e0a76e4d38b62777923407c360474e9b8671be7d2be3b7e3b7b37c95de9b51cb4aa4bfa161b2fbc7e218a6d20184804979 SHA512 bab2b32ab119e820067dd60b336e96797c2fddfa5cbbe619c12b0c27e19ab8fa8d3106cdc4956036f87b810bd1dab3a5f7a01b690d72b3c1e9ec9f10399bb95e
DIST sqlglot-17.16.1.tar.gz 8561327 BLAKE2B fce3362e91e91f92624337964ddd72ab198ecd368f77abce89ee7090aeb23efb79aecd93f76d7f8cd896c23d8cd99f0e068bdbc14906174eab6bd015e809f903 SHA512 c97bd12c1f889f77c279b10b5869806ac170301602020dcf7073ba70547702e1732a3354141694f7c4db8528bc1fd4e8bfe006f2ad81c4bf63153c148878b5e1
+DIST sqlglot-17.16.2.tar.gz 8562390 BLAKE2B f985f74765438c9b57a1df9ff1ad9cf43b7e81bf8c89cb328d39d0127661f5fd4153dccc6ec1fb73a8167d4e67e8a971c4f06cba7cab5796bda7726129bcf6f0 SHA512 2487f566078cf7ac84a8e3f3a70760c5f2d5b565e1479390883551531e53a69ec0ca581585b006a44529c39a21a70867082047746ec20939f2a1e1f2408aae34
diff --git a/dev-python/sqlglot/sqlglot-17.16.2.ebuild b/dev-python/sqlglot/sqlglot-17.16.2.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.16.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}