summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-01 16:35:17 +0300
committerMichał Górny <mgorny@gentoo.org>2023-08-01 16:42:13 +0200
commit029bb87795afbc26c6c8861bd8dd0b736bf89856 (patch)
treeee1238d92bde08d863ef07b46a2730d85843cb39 /dev-python/sqlglot
parentkde-plasma/plasma-sdk: add 5.27.7.1, drop 5.27.7 (diff)
downloadgentoo-029bb87795afbc26c6c8861bd8dd0b736bf89856.tar.gz
gentoo-029bb87795afbc26c6c8861bd8dd0b736bf89856.tar.bz2
gentoo-029bb87795afbc26c6c8861bd8dd0b736bf89856.zip
dev-python/sqlglot: add 17.9.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-17.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index b7dcfdb891a7..05b625b202f8 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,2 +1,3 @@
DIST sqlglot-17.8.4.tar.gz 8373260 BLAKE2B e3b67c940eb608a25705fd280c0165ad7f37db1fcda2f6bc55029af2ad673a789901fbb2e6af72b54d15b75bc84827afadb00cc965efdc3323587278a68f6cf5 SHA512 c1717e7e857ddb9ff700c739b76cd3714e57ae0f7b620593b4fdce53cbf8e37d39882fac1308c3277a236f695292ae1c15541e474d28bdd43d889c2756b172df
DIST sqlglot-17.8.6.tar.gz 8382262 BLAKE2B 70c14c50cbd673122e0560d41b26076ff2d22c75d611cb751ae3df9e5f98e8392440144edcb38bde272f5a95ac85a48cb85358a75dd9b53a1b72e8133964c15c SHA512 839d10ef3d589dd258a5297dc21846e0aafd145892e4c2650aa12ea16064da1dceacd9e1f9cbd6f804b8590435db61066cb01a92b3a1d88a69b1aa8dffaeb15b
+DIST sqlglot-17.9.0.tar.gz 8382270 BLAKE2B 86bd687906e7e2fca631021a0d77fbe91beb931ead70dd6d7b5a7255a5302412bede8b1e5abdc4e8ffb610640c3e3597ee1d78cbf6fe3d4e76947572bbec26ad SHA512 52b1eeece3854b9a0ed839a0f0f08af572d9e445a84d241af481bb104b49cba5a5af6b02a671343d69b4c2233f9e3f4c355969307e86d91544d32a94fdf4a5b4
diff --git a/dev-python/sqlglot/sqlglot-17.9.0.ebuild b/dev-python/sqlglot/sqlglot-17.9.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-17.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}